Problem Using Animation Control in 256 Colour Mode 
Author Message
 Problem Using Animation Control in 256 Colour Mode

Hi,


Quote:
>I'm trying to display a 256 colour AVI using the Animation Control in VB5.
>With the screen depth set to 256 colours, the AVI seems to be displayed in
>the 16 colour system palette. If I increase the screen depth to higher than
>256 colours, the AVI displays fine.

>I have tried the improved CCRP version of the animation control and have
the
>same problem. Is there a bug in the Comct232.dll?

The CCRP Animation control uses the same control as the MS version so it is
likely to be a problem in COMCTL32.DLL. I'll take a look and get back to
you...

Regards,

Jeremy Adams

CCRP: http://www.*-*-*.com/



Sun, 03 Sep 2000 03:00:00 GMT  
 Problem Using Animation Control in 256 Colour Mode

Hi,

Quote:
>The CCRP Animation control uses the same control as the MS version so it is
>likely to be a problem in COMCTL32.DLL. I'll take a look and get back to
>you...

I get the same problems as you describe here. I also tried a simple VC++ app
using the animation control and got the same result so it looks likely that
it's COMCTL32.DLL that's causing the problems. You may need to have a look
at using another method to play the AVI...

Regards,

Jeremy Adams

CCRP: http://www.zeode-sd.com/ccrp



Sun, 03 Sep 2000 03:00:00 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. Flood Filling problems in 256 colour mode

2. 256 Colour Bitmaps on 256 Colour Screen?!

3. 3d-demo program in 320x200 256 colour mode - 3d.zip [1/1]

4. BIG PROBLEM!!! PictureClip control and 256-color mode

5. Weird 256 colour palette problem with BitBlt()

6. 256 Colour Palette problems in VB4

7. 256 Colour Palette problems

8. 256 Colour Palette problems in VB4

9. Picture control in 256 colour resolution?

10. 256 colors and animation control

11. Palette Problems in 256 Color Mode

12. Palette Problems in 256 Color Mode

 

 
Powered by phpBB® Forum Software