Can't load ActiveX control in web browser 
Author Message
 Can't load ActiveX control in web browser

Hello,

I have created an ActiveX control using VB 6.0 that I wish to run in
Internet Explorer. I have uploaded it to the webserver and it works fine
from my development machine. However, when I use someone elses machine,
it gives the warning about unsigned activex controls where I say yes to
whether or not I want it installed. Then it looks as though it is
loading something but then says "Done" and there is only a small square
in the upper left hand corner of the window.

The html code I am using to display the ocx is:

<HTML>
<HEAD>
<TITLE>Desktop Assistant</TITLE>
</HEAD>
<OBJECT classid="clsid:2E20E63F-FDD0-496A-BC60-7FBDB7BDA758"
CODEBASE="MYOCX.ocx"></OBJECT>
</HTML>

I found the classid by looking in the development machine's registry.

Any help would be greatly appreciated.

Thanks,
Kevin.



Sat, 08 Feb 2003 03:00:00 GMT  
 Can't load ActiveX control in web browser
The client machine will also need all the required files for the OCX.
MSVBM60.DLL (and all its dependencies) and any other controls you used.

--
-Clint LaFever
http://lafever.iscool.net
Home of the Visual Basic Code Depot Add-In

VOTE for my wife in the Lycos Model Search 2000
http://clubs.lycos.com/live/Directory/PhotoAlbum.asp?CG=llfae5c88va13...
mohh08&AID=61792&query=fitdiva


Quote:
> Hello,

> I have created an ActiveX control using VB 6.0 that I wish to run in
> Internet Explorer. I have uploaded it to the webserver and it works fine
> from my development machine. However, when I use someone elses machine,
> it gives the warning about unsigned activex controls where I say yes to
> whether or not I want it installed. Then it looks as though it is
> loading something but then says "Done" and there is only a small square
> in the upper left hand corner of the window.

> The html code I am using to display the ocx is:

> <HTML>
> <HEAD>
> <TITLE>Desktop Assistant</TITLE>
> </HEAD>
> <OBJECT classid="clsid:2E20E63F-FDD0-496A-BC60-7FBDB7BDA758"
> CODEBASE="MYOCX.ocx"></OBJECT>
> </HTML>

> I found the classid by looking in the development machine's registry.

> Any help would be greatly appreciated.

> Thanks,
> Kevin.



Sat, 08 Feb 2003 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Can't load ActiveX control in web browser

2. Web Browser control - problem loading ActiveX controls

3. W2K Doesn't Load ActiveX Control But W98 and WXP Do Load ActiveX Control Correctly

4. VB6 Web Browser-Loading URL's from a sequential file

5. VB6 Web Browser-Loading URL's from a sequential file

6. VB6 Web Browser - Loading URL's from a sequential file

7. VB6 Web Browser-Loading URL's from a sequential file

8. 'Microsoft Web Browser Control'

9. Loading Text into web browser control

10. getting a complete load of wed page in web browser control

11. getting a complete load of wed page in web browser control

12. Loading bookmarks or Fav in Web Browser Control

 

 
Powered by phpBB® Forum Software