Can't get controls to display 
Author Message
 Can't get controls to display

Doug,
    I'm kind of a beginner with ActiveX controls myself, but maybe you need
a CODEBASE tag.  Check out the following article:

http://www.*-*-*.com/

Ray Maas



Quote:
> Hoping someone can help. I've done everthing I can find on MSDN but can't
> get my control to display on machines other than my dev box.

> No errors just the waiting for object icon, (not the red x), tas if not
> found.

> Attached is a copy of he inf file generated when I deploy.

> I also included the following snippet in the calling htm before the
control
> object. I don't know if I need it but am trying everything I find.

> <OBJECT CLASSID="clsid:5220cb21-c88d-11cf-b347-00aa00a28331">
>  <PARAM NAME="LPKPath"

VALUE=" http://www.*-*-*.com/ ;>
Quote:
> </OBJECT>

> Also all the dll's in the inf are in c:\windows\system
> msvbvm60.dll=msvbvm60.dll
> OLEAUT32.DLL=OLEAUT32.DLL
> OLEPRO32.DLL=OLEPRO32.DLL
> ASYCFILT.DLL=ASYCFILT.DLL
> STDOLE2.TLB=STDOLE2.TLB
> COMCAT.DLL=COMCAT.DLL

> What am I missing?????

> Thanks in advance.

> Doug Steckel




Mon, 04 Feb 2002 03:00:00 GMT  
 Can't get controls to display
Check the versions of the msvcrt.dll. I had a similar problem
which was solved by including version 6.00.8337.0 of this dll.

    Stephane van Hardeveld
    www.virtuosovision.nl

Ray Maas heeft geschreven in bericht ...

Quote:
>Doug,
>    I'm kind of a beginner with ActiveX controls myself, but maybe you need
>a CODEBASE tag.  Check out the following article:

>http://www.4guysfromrolla.com/webtech/091698-1.shtml

>Ray Maas



>> Hoping someone can help. I've done everthing I can find on MSDN but can't
>> get my control to display on machines other than my dev box.

>> No errors just the waiting for object icon, (not the red x), tas if not
>> found.

>> Attached is a copy of he inf file generated when I deploy.

>> I also included the following snippet in the calling htm before the
>control
>> object. I don't know if I need it but am trying everything I find.

>> <OBJECT CLASSID="clsid:5220cb21-c88d-11cf-b347-00aa00a28331">
>>  <PARAM NAME="LPKPath"
>VALUE="http://server.apci.com/cabinets/LabPcCtl.LPK">
>> </OBJECT>

>> Also all the dll's in the inf are in c:\windows\system
>> msvbvm60.dll=msvbvm60.dll
>> OLEAUT32.DLL=OLEAUT32.DLL
>> OLEPRO32.DLL=OLEPRO32.DLL
>> ASYCFILT.DLL=ASYCFILT.DLL
>> STDOLE2.TLB=STDOLE2.TLB
>> COMCAT.DLL=COMCAT.DLL

>> What am I missing?????

>> Thanks in advance.

>> Doug Steckel




Tue, 05 Feb 2002 03:00:00 GMT  
 Can't get controls to display
Have you registered your control before trying to run it? Your IDE will
register the executable on your dev box after it is built, but that won't
happen on your remote computer. Until DllRegisterServer() has been called
on the control, you won't be able to run it.

Jeff



Quote:
> Hoping someone can help. I've done everthing I can find on MSDN but can't
> get my control to display on machines other than my dev box.

> No errors just the waiting for object icon, (not the red x), tas if not
> found.

> Attached is a copy of he inf file generated when I deploy.

> I also included the following snippet in the calling htm before the
control
> object. I don't know if I need it but am trying everything I find.

> <OBJECT CLASSID="clsid:5220cb21-c88d-11cf-b347-00aa00a28331">
>  <PARAM NAME="LPKPath"

VALUE="http://server.apci.com/cabinets/LabPcCtl.LPK">
Quote:
> </OBJECT>

> Also all the dll's in the inf are in c:\windows\system
> msvbvm60.dll=msvbvm60.dll
> OLEAUT32.DLL=OLEAUT32.DLL
> OLEPRO32.DLL=OLEPRO32.DLL
> ASYCFILT.DLL=ASYCFILT.DLL
> STDOLE2.TLB=STDOLE2.TLB
> COMCAT.DLL=COMCAT.DLL

> What am I missing?????

> Thanks in advance.

> Doug Steckel




Thu, 07 Feb 2002 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. 'Canned' data in VB program

2. Getting Display Fonts set in Control Panel:Display

3. Help: Getting access to another window's display

4. Looking 4 Canned Control

5. Custom control won't display and problems with building dll's

6. Cancel a control's lostfocus before another control gets the focus

7. Getting IE control displayed in HTMLHelp

8. Getting a Control's Name Property

9. MS Calendar Control 10.0 doesn't display

10. Treeview Control display node's text like tooltiptext

11. Bound Picture control in VB3: can't display picture from .MDB file

12. Help: SSIndexTab don't display controls

 

 
Powered by phpBB® Forum Software