active X control:Class not registered...why ?? 
Author Message
 active X control:Class not registered...why ??

I created an Active X control, but I keep getting the
following error when I try to use my control in  a new
Standard EXE project:

"Class not registered. Looking for object with CLSID..."

Here are the steps I followed:

1)Create the control
2)Save the the project:Save project As
3)Save the control as *.ctl
4)Make *.ocx.
5)CLose all windows and start a new EXE  project.
(Now I try using the control, but I get the error).

However, after these steps, I can get the control to work
by doing the following:

1)Open the Active X project
2)Save control as *.ctl
  (a message box warns me that the name already exists, do
I want to overwrite ?, I say Yes)
3)close the project,
4)Open a new EXE project and insert the control.

Now everything works. But I am trying to understand why it
did not work the first time ?

BTW, I've done this several times  and I always get the
same behavior.

Thanks for your help.

Jordi



Sat, 16 Oct 2004 20:44:31 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. why the Inet control says it is not registered

2. Class not registered & data control error

3. DB Controls - Class Not Registered

4. Error drawing Inet Control on form (Class not registered)

5. CLASS NOT REGISTERED using Grid control - HELP

6. Error drawing Inet Control on form (Class not registered)

7. DAO 3.6 and Data Controls - Class not registered

8. MS Active X control downloads OK but home grown Active X Control will not download

9. MS Active X control downloads OK but home grown Active X Control will not download

10. Class of control was not a loaded control class - Reference Replaced with unknown .OCA file

11. Active X Not Registered

12. Library Not Registered opening Active Directory Tools and .vbs scripts

 

 
Powered by phpBB® Forum Software