Problem with SSTab and Frames 
Author Message
 Problem with SSTab and Frames

I am using the SSTab control with Frames on more then one of the tabs.  The
problem I am having is with tabbing.  As I tab from the last control on the
active tab, focus is set to a control on a Frame on an inactive tab.  I am
guessing this is happening because when a control is on a frame the frames
left property is set < 0 and not the left property of the control.

It is a rather awkward user interface to have the tabbing go to these
controls because they are essentialy invisible.

Has anyone else encountered this problem and have a work around.



Fri, 21 Apr 2000 03:00:00 GMT  
 Problem with SSTab and Frames

We have the same problem and have to disable all the frames in inactive
tabs
to deal with it.

Does anyone have a better way?



Quote:
> I am using the SSTab control with Frames on more then one of the tabs.
The
> problem I am having is with tabbing.  As I tab from the last control on
the
> active tab, focus is set to a control on a Frame on an inactive tab.  I
am
> guessing this is happening because when a control is on a frame the
frames
> left property is set < 0 and not the left property of the control.

> It is a rather awkward user interface to have the tabbing go to these
> controls because they are essentialy invisible.

> Has anyone else encountered this problem and have a work around.



Sat, 22 Apr 2000 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Using TabStrip/SSTab to dynamically load frames

2. SSTAB and Frame

3. Dynamically Loaded/Unloaded Controls using SSTab and Frames

4. sstab - move a frame on Tab x to Tab y at run time

5. Resizing frames inside SSTab

6. SStab , Event for frame...

7. help w/ rtf, scrolls, sstabs and frames

8. help w/ rtf, scrolls, sstabs and frames

9. Chosing Frame content in a 2 framed page from a 1 framed page

10. SStab Problem - Dragover event

11. Having problems with SSTabs OCX

12. SSTab Problem

 

 
Powered by phpBB® Forum Software