Access Keys on Frames Don't Work 
Author Message
 Access Keys on Frames Don't Work

I've been looking at the possibility of putting Access Keys on Frames.  I
assumed that hitting the access key would move focus to the first enabled
control in the associated frame. However, I've encountered some really
weird things happening when I have access keys defined on frames.

Firstly, if I just have Frames on a form, no matter what access key I hit,
focus always moves to the textbox with the lowest tab stop.

Secondly, if I have command buttons on the form as well, hitting the access
key for any frame always invokes the command button with the lowest tab
stop.  The command button might have no access key defined, or a different
access key.

It looks like this has something to the way access keys are either handled
by VB or by the Windows Operating System.  Nothing in the VB online help
indicates that access keys on frames shouldn't work.

I am working with VB 4 32 Bit on Windows NT 4. I've also checked this out
on a copy of VB 5 beta on Windows NT 4 with exactly the same results.

Anyone got any ideas or good (i.e. quick and easy to implement)
workarounds?

Thanks

Cathal



Tue, 20 Jul 1999 03:00:00 GMT  
 Access Keys on Frames Don't Work

Have you tried setting the form to preview keys?  This *might* be what you
need.
Dave



Tue, 20 Jul 1999 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Access Keys on Frames Don't Work

2. Access Keys on Frames Don't Work

3. Access Keys on Frames Don't Work

4. Frame in IE 30 don't work anymore

5. Delete key don't work

6. Cursor keys don't work in the command window when debugging

7. tab and arrow keys don't work after debugging

8. Function keys don't work until I display help

9. shortcut keys don't work while my active control is the datagrid

10. MSFlexGrid - Keyboard Arrow Keys Don't Work.

11. CR: Arrow keys don't work in Smart Viewer

12. MovePrevious don't work but the MoveNext work's fine

 

 
Powered by phpBB® Forum Software