deadlocked with SQL Server 7 and MTS 
Author Message
 deadlocked with SQL Server 7 and MTS

hello,
i am trying to test my web application with a stress application, when i run
the test with 1 client concurrent it works fine, but whe i run the test with
10 clients it fails trying to run a insert command in the SQL Server 7
database
The server is:
Windows NT Server 4.0 SP6a
SQL Server 7.0 SP3
Ms ADC 2.5
MTS 2.0
The error i get is:
Your transaction (process ID #14) was deadlocked with another process and
has been chosen as the deadlock victim. Rerun your transaction.
The business objects are runing in MTS

This is how i run the command:

Dim rs As ADODB.Recordset, cmd As ADODB.Command, conn As ADODB.Connection
    Set rs = CtxCreateObject("ADODB.Recordset")
    Set cmd = CtxCreateObject("ADODB.Command")

    'Run the Command
    cmd.ActiveConnection = BuildConnectionString(Role)
    cmd.CommandText = strSP
    cmd.CommandType = adCmdText

    rs.CursorLocation = adUseClient
    rs.Open cmd, , adOpenKeyset, adLockReadOnly
    Set cmd.ActiveConnection = Nothing
    Set cmd = Nothing
    Set rs.ActiveConnection = Nothing

    Set RunSQLReturnRS = rs

Any help will be appreciate
Thanks
Alfonso Ordonez



Sun, 29 Jun 2003 08:50:28 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. deadlocked with SQL Server 7 and MTS

2. DAO Update Deadlocks SQL Server 6.5, but not 6.0

3. Deadlocked with SQL Server 7

4. Simulating Deadlock with VB/ADO/Sql Server

5. Get Username or Computername after lock (or deadlock) errors from MS SQL server (7 or 6.5)

6. Design Question: Call .dll from SQL Server VS MTS

7. Design Question: Calling .dll from SQL Server VS MTS

8. MTS, WinSock, SQL Server

9. Problem with updating SQL SERVER database through MTS

10. ADO, MTS, SQL Server RecordSet Questions

11. MTS VB and clsutered SQL server 7.0

12. Transaction scope using ADO with SQL Server 7 and MTS

 

 
Powered by phpBB® Forum Software