COM Problems when compiled under IIS 5 
Author Message
 COM Problems when compiled under IIS 5

Hi All,
I made a COM DLL under Visual Basic 6.0 that just uses the SHELL function to
run an executable. I made an EXE file that insatiates the COM and run an
executable. The thing is, when I select run from the IDE in visual basic, it
works fine, by opening the program requested. However, when I compile the
COM and try to instatiate it, it will run the program in the background
(appearing in the task list), but doesn't show it. I checked the "Allow
Service to Interact with Desktop" checkbox for WWW Publishing Service, I
gave an execute permission on the directory, but this still won't work. I'm
sure it's a permission problem, but I don't know what it is.
HELP
--
regards,
Fadi El-Eter, ABEO


Sun, 24 Oct 2004 04:41:08 GMT  
 COM Problems when compiled under IIS 5

Hi All,
I made a COM DLL under Visual Basic 6.0 that just uses the SHELL function to
run an executable. I made an EXE file that insatiates the COM and run an
executable. The thing is, when I select run from the IDE in visual basic, it
works fine, by opening the program requested. However, when I compile the
COM and try to instatiate it, it will run the program in the background
(appearing in the task list), but doesn't show it. I checked the "Allow
Service to Interact with Desktop" checkbox for WWW Publishing Service, I
gave an execute permission on the directory, but this still won't work. I'm
sure it's a permission problem, but I don't know what it is.
HELP
--
regards,
Fadi El-Eter, ABEO

--
regards,
Fadi El-Eter, ABEO



Mon, 25 Oct 2004 05:02:31 GMT  
 COM Problems when compiled under IIS 5
run dcomcnfg and be sure you have the security setting set for the
object.class name.

You'll have to play around with the settings (I'm currently trying to figure
out the correct set myself)


Quote:

> Hi All,
> I made a COM DLL under Visual Basic 6.0 that just uses the SHELL function
to
> run an executable. I made an EXE file that insatiates the COM and run an
> executable. The thing is, when I select run from the IDE in visual basic,
it
> works fine, by opening the program requested. However, when I compile the
> COM and try to instatiate it, it will run the program in the background
> (appearing in the task list), but doesn't show it. I checked the "Allow
> Service to Interact with Desktop" checkbox for WWW Publishing Service, I
> gave an execute permission on the directory, but this still won't work.
I'm
> sure it's a permission problem, but I don't know what it is.
> HELP
> --
> regards,
> Fadi El-Eter, ABEO

> --
> regards,
> Fadi El-Eter, ABEO



Mon, 25 Oct 2004 05:16:06 GMT  
 COM Problems when compiled under IIS 5
I made a mistake in my last email, I said that I created an exe file to
instatiate the COM, but it was in fact an ASP file, sorry about that.
Anyways, I ran dcomcnfg
before and it didn't work. The problem is when I try to run the asp file
under IIS, the program to be executed appears in the task list but not on
the destkop. I'm quite sure that this is a security problem under IIS 5.0.

--
regards,
Fadi El-Eter, ABEO



Mon, 25 Oct 2004 04:33:19 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. Problem compiling IIS Application

2. COM MTS VB IIS Problem

3. Newbie: COM based Network Login Validator, IIS Isolation Level problem

4. com problem with web server (IIS 5.0)

5. Problem compiling VB COM Add-In for different Outlook Versions

6. IIS app runs compiled, but not from IDE

7. IIS app runs compiled, but not from IDE

8. VB6 IIS Application won't run after compile

9. Getsettings not working in compiled IIS app.

10. Enter Network password when using COM and IIS

11. COM forn ASP under IIS 5.0

12. IIS shuts down periodically when using ASP, RDS and COM

 

 
Powered by phpBB® Forum Software