picturebox or image control bug, HELP 
Author Message
 picturebox or image control bug, HELP
Hi,
I now downloaded & installed sp5, so i have VB6.0, SP5, win98

I take a 5*5 bitmap of an X. i tried it in BMP (mono, 16,256,24bit), GIF,
JPG.
I take (design or run time) a picture box or image control, and set its
picture property to the bitmap file.
at least one line is missing (usually top line, sometimes also right line),
and the rest of the image is stretched to fit 5*5 pixels.
the files are opened OK in both paintbrush and Kodak imaging, and "view as
web page" of windows explorer.

What is going on here??? is it just my computer? is it just me?
any help would be greatly appreciated.
Omri Barak




Thu, 29 Jan 2004 14:03:19 GMT  
 picturebox or image control bug, HELP
No answer from me, but you're not the first to cite this. From the few
threads I've read I recall square being stated each time (of course I can
barely recall my name most daze).  Just for added info, try another aspect
ratio!
For what it's worth,
Billy Joe


Hi,
I now downloaded & installed sp5, so i have VB6.0, SP5, win98

I take a 5*5 bitmap of an X. i tried it in BMP (mono, 16,256,24bit), GIF,
JPG.
I take (design or run time) a picture box or image control, and set its
picture property to the bitmap file.
at least one line is missing (usually top line, sometimes also right line),
and the rest of the image is stretched to fit 5*5 pixels.
the files are opened OK in both paintbrush and Kodak imaging, and "view as
web page" of windows explorer.

What is going on here??? is it just my computer? is it just me?
any help would be greatly appreciated.
Omri Barak



Thu, 29 Jan 2004 13:49:33 GMT  
 picturebox or image control bug, HELP
thanks,
i have one workaround, which is to use an invisible picturebox, and
PaintPicture, but it still seems like there's a bug.


Quote:
> No answer from me, but you're not the first to cite this. From the few
> threads I've read I recall square being stated each time (of course I can
> barely recall my name most daze).  Just for added info, try another aspect
> ratio!
> For what it's worth,
> Billy Joe



> Hi,
> I now downloaded & installed sp5, so i have VB6.0, SP5, win98

> I take a 5*5 bitmap of an X. i tried it in BMP (mono, 16,256,24bit), GIF,
> JPG.
> I take (design or run time) a picture box or image control, and set its
> picture property to the bitmap file.
> at least one line is missing (usually top line, sometimes also right
line),
> and the rest of the image is stretched to fit 5*5 pixels.
> the files are opened OK in both paintbrush and Kodak imaging, and "view as
> web page" of windows explorer.

> What is going on here??? is it just my computer? is it just me?
> any help would be greatly appreciated.
> Omri Barak




Thu, 29 Jan 2004 15:05:54 GMT  
 picturebox or image control bug, HELP
Omri,
I've done a few (very limited) tests of square Picture Box loads and
PaintPictures and NOT seen this bug.
When more than one person experiences the same anomaly however I sure figure
that the API coder F'd up.
Would you care to share the workaround? For those of us yet to figure it
out?
Billy Joe


thanks,
i have one workaround, which is to use an invisible picturebox, and
PaintPicture, but it still seems like there's a bug.



Thu, 29 Jan 2004 14:35:01 GMT  
 picturebox or image control bug, HELP
the bug (i think) is in the picturebox or image control drawing the bitmap.
the picture property is the file loaded from disk, so when you save the
file, or use PaintPicture (which doesnt have the bug), everything is ok.
however, when you use the image property, or just view the bitmap with
sufficient zoom, you see that the top pixel line is missing.

the workaround (not mine):
create an auxillery picturebox: pic_aux
pic_aux.visible = false
pic_aux.picture = <the bitmap>

now the real picturebox: picture1
picture1.autoredraw=true
picture1.PaintPicture pic_aux.Picture, 0, 0

it can probably be done also with a picture object and LoadPicture,
consuming less resources.


Quote:
> Omri,
> I've done a few (very limited) tests of square Picture Box loads and
> PaintPictures and NOT seen this bug.
> When more than one person experiences the same anomaly however I sure
figure
> that the API coder F'd up.
> Would you care to share the workaround? For those of us yet to figure it
> out?
> Billy Joe



> thanks,
> i have one workaround, which is to use an invisible picturebox, and
> PaintPicture, but it still seems like there's a bug.



Thu, 29 Jan 2004 16:00:34 GMT  
 picturebox or image control bug, HELP
Omri,
Thanks for sharing. I have no idea where I picked up the habit of using
Picture boxes exactly as you describe. Probably because I first used Image
boxes for their "stretchablilty" until I learned to use PaintPicture from an
invisible source (BitBlt doesn't seem to share that feature?) to
resize/scale images. As a result, I guess I've not encountered the "bug"
Regards,
Billy Joe


the bug (i think) is in the picturebox or image control drawing the bitmap.
the picture property is the file loaded from disk, so when you save the
file, or use PaintPicture (which doesnt have the bug), everything is ok.
however, when you use the image property, or just view the bitmap with
sufficient zoom, you see that the top pixel line is missing.

the workaround (not mine):
create an auxillery picturebox: pic_aux
pic_aux.visible = false
pic_aux.picture = <the bitmap>

now the real picturebox: picture1
picture1.autoredraw=true
picture1.PaintPicture pic_aux.Picture, 0, 0

it can probably be done also with a picture object and LoadPicture,
consuming less resources.


Quote:
> Omri,
> I've done a few (very limited) tests of square Picture Box loads and
> PaintPictures and NOT seen this bug.
> When more than one person experiences the same anomaly however I sure
figure
> that the API coder F'd up.
> Would you care to share the workaround? For those of us yet to figure it
> out?
> Billy Joe



> thanks,
> i have one workaround, which is to use an invisible picturebox, and
> PaintPicture, but it still seems like there's a bug.



Fri, 30 Jan 2004 04:05:31 GMT  
 
 [ 6 post ] 

 Relevant Pages 

1. Help!! Loading PictureBox FromStream and PictureBox.Image.Save

2. load a Jpeg image into a picturebox or image control

3. Loaded image in Image or PictureBox control

4. Error loading GIF or JPG image in PictureBox or Image controls

5. Color Count of image in an image (or picturebox) control

6. HELP on Image/Picturebox controls

7. Is this a bug with picturebox control?

8. loading image or picturebox control from access 3.0 db w/ DAO

9. Image control over pictureBox

10. Image Controls within a PictureBox containing Vertical Scroll Bars

11. Save an image using PictureBox control?

12. multiple graphics in PictureBox or Image control?

 

 
Powered by phpBB® Forum Software