VB6 SP5 not compatible with pre SP5??? 
Author Message
 VB6 SP5 not compatible with pre SP5???

In an education environment, our students were working on projects,
saving them to CD, carrying them home and finishing them.  After
adding SP5 to our class, they can no longer do this.  Everybody
seems to have different errors, but it looks like SP5 is not
compatible with other VB6 Service Packs.  Even when they carry
the project to our lab that has the same machines and SP4,
they have problems.  But they can bring the project back to the
class with SP5 and they work fine there.

We had none of these problems before SP5, just the problems that
SP5 fixed (which it did fix).

Any ideas?

Ray



Tue, 16 Dec 2003 01:28:38 GMT  
 VB6 SP5 not compatible with pre SP5???
Hi Ray:

Quote:
> seems to have different errors, but it looks like SP5 is not
> compatible with other VB6 Service Packs.  Even when they carry
> the project to our lab that has the same machines and SP4,
> they have problems.  But they can bring the project back to the
> class with SP5 and they work fine there.

So why don't you install SP5 on all the machines?

Doug.



Tue, 16 Dec 2003 01:54:57 GMT  
 VB6 SP5 not compatible with pre SP5???

Quote:

> Hi Ray:

> > seems to have different errors, but it looks like SP5 is not
> > compatible with other VB6 Service Packs.  Even when they carry
> > the project to our lab that has the same machines and SP4,
> > they have problems.  But they can bring the project back to the
> > class with SP5 and they work fine there.

> So why don't you install SP5 on all the machines?

> Doug.

We could install it in the lab, but the students all have a special
Educational Institution VB "Working Model" version that comes with
the McGraw-Hill textbook.  Not sure what the Service Pack would do
when it sees that.

More details are that if you take a project that was working with
the student version, open and close it under SP5, it no longer works
with the student version, or under VB6 SP4.  We did not have this
problem with SP4.  After SP5 has done it's thing, the students can't
save, read, load or compile.  The compile error they get is -
Data member not found, Move/compile event does not recognize record
set.

I can understand things not being compatible with different versions,
but who would expect a Service Pack to make things that incompatible?

Ray



Tue, 16 Dec 2003 04:26:43 GMT  
 VB6 SP5 not compatible with pre SP5???
Ray,

I have SP4 on my machine now.  If you send me one of these projects,
I'll get it to load, upgrade to SP5 and analyze the error.

Even though this is a pervasive problem in your lab, I suspect it's
something small and easy to correct.


Quote:
> In an education environment, our students were working on projects,
> saving them to CD, carrying them home and finishing them.  After
> adding SP5 to our class, they can no longer do this.  Everybody
> seems to have different errors, but it looks like SP5 is not
> compatible with other VB6 Service Packs.  Even when they carry
> the project to our lab that has the same machines and SP4,
> they have problems.  But they can bring the project back to the
> class with SP5 and they work fine there.

> We had none of these problems before SP5, just the problems that
> SP5 fixed (which it did fix).

> Any ideas?

> Ray



Tue, 16 Dec 2003 07:11:25 GMT  
 VB6 SP5 not compatible with pre SP5???
Hi Ray:

Quote:
> We could install it in the lab, but the students all have a special
> Educational Institution VB "Working Model" version that comes with
> the McGraw-Hill textbook.  Not sure what the Service Pack would do
> when it sees that.

Perhaps you could use one machine as a "Test bed" and install on it only.
At least that way if installing the SP screws something up, at least it's only on one machine.

Quote:
> More details are that if you take a project that was working with
> the student version, open and close it under SP5, it no longer works
> with the student version, or under VB6 SP4.

Until you track down the problem, perhaps the only immediate workaround would be to not use SP5 at all.

Quote:
> We did not have this
> problem with SP4.  After SP5 has done it's thing, the students can't
> save, read, load or compile.  The compile error they get is -
> Data member not found, Move/compile event does not recognize record
> set.

Can you provide a code example (copy and paste) that demonstrates the problem.
Did VB create a *.log file for the form that is giving you the problem (if you know which one that is)?

Quote:
> I can understand things not being compatible with different versions,
> but who would expect a Service Pack to make things that incompatible?

In some cases, it does make sense.  For example, if you build your app using a newer version of a control (which the SPs do
upgrade), and then try and open that project on a machine with an older control, the newer properites, methods, interfaces, etc. of
that control would not be available.

Doug.



Thu, 18 Dec 2003 03:12:59 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. memory not realeased (also leaks) when Loading/Unloading a form in VB6 SP5

2. Problem : Bound UserControl not updating recordset - VB6 SP5

3. VB6 - SP5 exe generates drWatson during OLE communication with VB6 - SP3 exe

4. VB6 With SP5 and Access 2000

5. VB6 SP5 project size limit with WinXP?

6. VB6 sp5 question

7. VB6 (SP5) & Finding Control Occurrences

8. packager VB6 (SP5)

9. Warning about VB6 SP5 and Windows 2000

10. LIKE query gives different results in Access 2000 and VB6 SP5

11. Help with VB6(SP5) API Loop Function!

12. VB6 (SP5): Package and Deployment Wizard Dependency File

 

 
Powered by phpBB® Forum Software