Treeview 6.0 Node Tip Bug 
Author Message
 Treeview 6.0 Node Tip Bug

Hi there,
        Please help if you can !!!!
        Is there a bug fix to the treeview control which
comes with common control 6.0, it has problem with node
tip when the node text (name) is a long one. The Node tip
is displayed very slowly and if you have many node in
series which all have long names, the treeview node text
simply does not paint correclty as you move the mouse
along the tree node, Please if help, I've been using
Treeview 5.0 because it does not have this problem !!!


Sat, 25 Sep 2004 00:49:42 GMT  
 Treeview 6.0 Node Tip Bug

on Mon, 8 Apr 2002 09:49:42 -0700 bearing the following
fruit:

Quote:
>Hi there,
>        Please help if you can !!!!
>        Is there a bug fix to the treeview control which
>comes with common control 6.0, it has problem with node
>tip when the node text (name) is a long one. The Node tip
>is displayed very slowly and if you have many node in
>series which all have long names, the treeview node text
>simply does not paint correclty as you move the mouse
>along the tree node, Please if help, I've been using
>Treeview 5.0 because it does not have this problem !!!

Post a small example that reproduced the problem. I use the
treeview all the time and have not experienced this.


Sat, 25 Sep 2004 15:34:11 GMT  
 Treeview 6.0 Node Tip Bug

Hi Jan, thank you for responding, I attached a sample with
both a treeview control 6.0 and treeview control 5.0, move
the mouse up and down both of the trees and see the
difference. than you

Quote:
>-----Original Message-----

>on Mon, 8 Apr 2002 09:49:42 -0700 bearing the following
>fruit:

>>Hi there,
>>        Please help if you can !!!!
>>        Is there a bug fix to the treeview control which
>>comes with common control 6.0, it has problem with node
>>tip when the node text (name) is a long one. The Node
tip
>>is displayed very slowly and if you have many node in
>>series which all have long names, the treeview node text
>>simply does not paint correclty as you move the mouse
>>along the tree node, Please if help, I've been using
>>Treeview 5.0 because it does not have this problem !!!

>Post a small example that reproduced the problem. I use
the
>treeview all the time and have not experienced this.

>.

  TView Sample.zip
2K Download


Sat, 25 Sep 2004 21:06:20 GMT  
 Treeview 6.0 Node Tip Bug

on Tue, 9 Apr 2002 06:06:20 -0700 bearing the following
fruit:

Quote:
>This is a multi-part message in MIME format.

>------=_NextPart_000_02FF_01C1DF8C.AB7B3B00
>Content-Type: text/plain;
>    charset="iso-8859-1"
>Content-Transfer-Encoding: 7bit

>Hi Jan, thank you for responding, I attached a sample with
>both a treeview control 6.0 and treeview control 5.0, move
>the mouse up and down both of the trees and see the
>difference. than you

Unfortunately this isn't the place to post binaries and I'm
not a fan of decoding any unknown quantity. I'd prefer a
short code sample which reproduces the problem. I can create
the project myself.

ps : please post in plain text

J

Quote:
>>-----Original Message-----

>>on Mon, 8 Apr 2002 09:49:42 -0700 bearing the following
>>fruit:

>>>Hi there,
>>>        Please help if you can !!!!
>>>        Is there a bug fix to the treeview control which
>>>comes with common control 6.0, it has problem with node
>>>tip when the node text (name) is a long one. The Node
>tip
>>>is displayed very slowly and if you have many node in
>>>series which all have long names, the treeview node text
>>>simply does not paint correclty as you move the mouse
>>>along the tree node, Please if help, I've been using
>>>Treeview 5.0 because it does not have this problem !!!

>>Post a small example that reproduced the problem. I use
>the
>>treeview all the time and have not experienced this.

>>.

<SNIP>


Sat, 25 Sep 2004 21:41:42 GMT  
 Treeview 6.0 Node Tip Bug
Hi,
  just add two treeviews, one from common controls 6.0
(Treeview1) and then the other from common controls 5.0
(Treeview2) and post the following code in the form:

Private Sub Form_Load()
For i = 1 To 100
    TreeView1.Nodes.Add , , , i & " This is a very longe
node name move mouse up and down the tree"
    TreeView2.Nodes.Add , , , i & " This is a very longe
node name move mouse up and down the tree"
Next

End Sub

Quote:
>-----Original Message-----

>on Tue, 9 Apr 2002 06:06:20 -0700 bearing the following
>fruit:

>>This is a multi-part message in MIME format.

>>------=_NextPart_000_02FF_01C1DF8C.AB7B3B00
>>Content-Type: text/plain;
>>        charset="iso-8859-1"
>>Content-Transfer-Encoding: 7bit

>>Hi Jan, thank you for responding, I attached a sample
with
>>both a treeview control 6.0 and treeview control 5.0,
move
>>the mouse up and down both of the trees and see the
>>difference. than you

>Unfortunately this isn't the place to post binaries and
I'm
>not a fan of decoding any unknown quantity. I'd prefer a
>short code sample which reproduces the problem. I can
create
>the project myself.

>ps : please post in plain text

>J
>>>-----Original Message-----

released
>>>on Mon, 8 Apr 2002 09:49:42 -0700 bearing the following
>>>fruit:

>>>>Hi there,
>>>>        Please help if you can !!!!
>>>>        Is there a bug fix to the treeview control
which
>>>>comes with common control 6.0, it has problem with
node
>>>>tip when the node text (name) is a long one. The Node
>>tip
>>>>is displayed very slowly and if you have many node in
>>>>series which all have long names, the treeview node
text
>>>>simply does not paint correclty as you move the mouse
>>>>along the tree node, Please if help, I've been using
>>>>Treeview 5.0 because it does not have this problem !!!

>>>Post a small example that reproduced the problem. I use
>>the
>>>treeview all the time and have not experienced this.

>>>.

><SNIP>
>.



Sat, 25 Sep 2004 22:25:04 GMT  
 Treeview 6.0 Node Tip Bug

on Tue, 9 Apr 2002 07:25:04 -0700 bearing the following
fruit:

Quote:
>Hi,
>  just add two treeviews, one from common controls 6.0
>(Treeview1) and then the other from common controls 5.0
>(Treeview2) and post the following code in the form:

>Private Sub Form_Load()
>For i = 1 To 100
>    TreeView1.Nodes.Add , , , i & " This is a very longe
>node name move mouse up and down the tree"
>    TreeView2.Nodes.Add , , , i & " This is a very longe
>node name move mouse up and down the tree"
>Next

>End Sub

OK, just tried this. I can't see any percievable difference.
I'm running VB6SP3 NT4 IE5.5

J

Quote:
>>-----Original Message-----

>>on Tue, 9 Apr 2002 06:06:20 -0700 bearing the following
>>fruit:

>>>This is a multi-part message in MIME format.

>>>------=_NextPart_000_02FF_01C1DF8C.AB7B3B00
>>>Content-Type: text/plain;
>>>    charset="iso-8859-1"
>>>Content-Transfer-Encoding: 7bit

>>>Hi Jan, thank you for responding, I attached a sample
>with
>>>both a treeview control 6.0 and treeview control 5.0,
>move
>>>the mouse up and down both of the trees and see the
>>>difference. than you

>>Unfortunately this isn't the place to post binaries and
>I'm
>>not a fan of decoding any unknown quantity. I'd prefer a
>>short code sample which reproduces the problem. I can
>create
>>the project myself.

>>ps : please post in plain text

>>J
>>>>-----Original Message-----

>released
>>>>on Mon, 8 Apr 2002 09:49:42 -0700 bearing the following
>>>>fruit:

>>>>>Hi there,
>>>>>        Please help if you can !!!!
>>>>>        Is there a bug fix to the treeview control
>which
>>>>>comes with common control 6.0, it has problem with
>node
>>>>>tip when the node text (name) is a long one. The Node
>>>tip
>>>>>is displayed very slowly and if you have many node in
>>>>>series which all have long names, the treeview node
>text
>>>>>simply does not paint correclty as you move the mouse
>>>>>along the tree node, Please if help, I've been using
>>>>>Treeview 5.0 because it does not have this problem !!!

>>>>Post a small example that reproduced the problem. I use
>>>the
>>>>treeview all the time and have not experienced this.

>>>>.

>><SNIP>
>>.



Sun, 26 Sep 2004 00:01:54 GMT  
 Treeview 6.0 Node Tip Bug
I'm then using VB without any service packes installed,
since it worked fine with you. I check the about and it
does not specify any service packes installed and I did
not install any, so, I think this is the reasone I'm
having the problem with TreeView 6.0, thank you :-)

Quote:
>-----Original Message-----

>on Tue, 9 Apr 2002 07:25:04 -0700 bearing the following
>fruit:

>>Hi,
>>  just add two treeviews, one from common controls 6.0
>>(Treeview1) and then the other from common controls 5.0
>>(Treeview2) and post the following code in the form:

>>Private Sub Form_Load()
>>For i = 1 To 100
>>    TreeView1.Nodes.Add , , , i & " This is a very longe
>>node name move mouse up and down the tree"
>>    TreeView2.Nodes.Add , , , i & " This is a very longe
>>node name move mouse up and down the tree"
>>Next

>>End Sub

>OK, just tried this. I can't see any percievable
difference.
>I'm running VB6SP3 NT4 IE5.5

>J

>>>-----Original Message-----

released
>>>on Tue, 9 Apr 2002 06:06:20 -0700 bearing the following
>>>fruit:

>>>>This is a multi-part message in MIME format.

>>>>------=_NextPart_000_02FF_01C1DF8C.AB7B3B00
>>>>Content-Type: text/plain;
>>>>        charset="iso-8859-1"
>>>>Content-Transfer-Encoding: 7bit

>>>>Hi Jan, thank you for responding, I attached a sample
>>with
>>>>both a treeview control 6.0 and treeview control 5.0,
>>move
>>>>the mouse up and down both of the trees and see the
>>>>difference. than you

>>>Unfortunately this isn't the place to post binaries and
>>I'm
>>>not a fan of decoding any unknown quantity. I'd prefer a
>>>short code sample which reproduces the problem. I can
>>create
>>>the project myself.

>>>ps : please post in plain text

>>>J
>>>>>-----Original Message-----

>>released
>>>>>on Mon, 8 Apr 2002 09:49:42 -0700 bearing the
following
>>>>>fruit:

>>>>>>Hi there,
>>>>>>        Please help if you can !!!!
>>>>>>        Is there a bug fix to the treeview control
>>which
>>>>>>comes with common control 6.0, it has problem with
>>node
>>>>>>tip when the node text (name) is a long one. The
Node
>>>>tip
>>>>>>is displayed very slowly and if you have many node
in
>>>>>>series which all have long names, the treeview node
>>text
>>>>>>simply does not paint correclty as you move the
mouse
>>>>>>along the tree node, Please if help, I've been using
>>>>>>Treeview 5.0 because it does not have this
problem !!!

>>>>>Post a small example that reproduced the problem. I
use
>>>>the
>>>>>treeview all the time and have not experienced this.

>>>>>.

>>><SNIP>
>>>.

>.



Sun, 26 Sep 2004 00:23:28 GMT  
 Treeview 6.0 Node Tip Bug
The difference is only noticeable with animated tooltip effects, for which
you need Win98/Win2k or higher. The problem is that the v6 TreeView insists
on performing the complete slide animation every time it displays a tooltip,
causing alot of flickering when moving the mouse down the tree.

--
Kevin Westhead


Quote:
> OK, just tried this. I can't see any percievable difference.
> I'm running VB6SP3 NT4 IE5.5



Sun, 26 Sep 2004 06:29:54 GMT  
 Treeview 6.0 Node Tip Bug
The problem still exists on win2000 and even on winXP.

Quote:
>-----Original Message-----
>The difference is only noticeable with animated tooltip
effects, for which
>you need Win98/Win2k or higher. The problem is that the
v6 TreeView insists
>on performing the complete slide animation every time it
displays a tooltip,
>causing alot of flickering when moving the mouse down the
tree.

>--
>Kevin Westhead


message

>> OK, just tried this. I can't see any percievable
difference.
>> I'm running VB6SP3 NT4 IE5.5

>.



Tue, 28 Sep 2004 10:09:30 GMT  
 Treeview 6.0 Node Tip Bug
Which is as expected because both OS' support tooltip animation. <g>

I would suggest that you stick with the VB5 tree view control and use the
common controls API to extend it if you need to. The VB6 controls were
statically linked to comctl32.dll, therefore they are tied to whatever
version MS were using when they built the OCX. This is why the VB6 controls
don't look right in XP even when you use the common controls manifest.

--
Kevin Westhead


Quote:
> The problem still exists on win2000 and even on winXP.



Tue, 28 Sep 2004 18:13:13 GMT  
 Treeview 6.0 Node Tip Bug
I am using Visual Basic 6.0 SP5 on Windows XP and I see the same problem.
Having just moved to VB6 from VB5 and from Win NT to Win XP, I wasn't sure
if it was a bug in VB or something specific to the OS.

I think it is with VB, but am currently waiting to test this on an NT PC in
the office.

Brian


Quote:

> on Tue, 9 Apr 2002 07:25:04 -0700 bearing the following
> fruit:

> >Hi,
> >  just add two treeviews, one from common controls 6.0
> >(Treeview1) and then the other from common controls 5.0
> >(Treeview2) and post the following code in the form:

> >Private Sub Form_Load()
> >For i = 1 To 100
> >    TreeView1.Nodes.Add , , , i & " This is a very longe
> >node name move mouse up and down the tree"
> >    TreeView2.Nodes.Add , , , i & " This is a very longe
> >node name move mouse up and down the tree"
> >Next

> >End Sub

> OK, just tried this. I can't see any percievable difference.
> I'm running VB6SP3 NT4 IE5.5

> J

> >>-----Original Message-----

> >>on Tue, 9 Apr 2002 06:06:20 -0700 bearing the following
> >>fruit:

> >>>This is a multi-part message in MIME format.

> >>>------=_NextPart_000_02FF_01C1DF8C.AB7B3B00
> >>>Content-Type: text/plain;
> >>> charset="iso-8859-1"
> >>>Content-Transfer-Encoding: 7bit

> >>>Hi Jan, thank you for responding, I attached a sample
> >with
> >>>both a treeview control 6.0 and treeview control 5.0,
> >move
> >>>the mouse up and down both of the trees and see the
> >>>difference. than you

> >>Unfortunately this isn't the place to post binaries and
> >I'm
> >>not a fan of decoding any unknown quantity. I'd prefer a
> >>short code sample which reproduces the problem. I can
> >create
> >>the project myself.

> >>ps : please post in plain text

> >>J
> >>>>-----Original Message-----

> >released
> >>>>on Mon, 8 Apr 2002 09:49:42 -0700 bearing the following
> >>>>fruit:

> >>>>>Hi there,
> >>>>>        Please help if you can !!!!
> >>>>>        Is there a bug fix to the treeview control
> >which
> >>>>>comes with common control 6.0, it has problem with
> >node
> >>>>>tip when the node text (name) is a long one. The Node
> >>>tip
> >>>>>is displayed very slowly and if you have many node in
> >>>>>series which all have long names, the treeview node
> >text
> >>>>>simply does not paint correclty as you move the mouse
> >>>>>along the tree node, Please if help, I've been using
> >>>>>Treeview 5.0 because it does not have this problem !!!

> >>>>Post a small example that reproduced the problem. I use
> >>>the
> >>>>treeview all the time and have not experienced this.

> >>>>.

> >><SNIP>
> >>.



Tue, 28 Sep 2004 18:39:28 GMT  
 Treeview 6.0 Node Tip Bug
Hi, I've been using TV 5.0 to avoid this problem, but as
you know when I package a program, both common controls
6.0 (for other controls) and common controls 5.0 (for the
TV only) have to be included with the package which in
turn will increase the size of the package. That's whay
I've been trying to find a fix to this bug. Thanks for the
help :-)
Quote:
>-----Original Message-----
>Which is as expected because both OS' support tooltip
animation. <g>

>I would suggest that you stick with the VB5 tree view
control and use the
>common controls API to extend it if you need to. The VB6
controls were
>statically linked to comctl32.dll, therefore they are
tied to whatever
>version MS were using when they built the OCX. This is

why the VB6 controls
Quote:
>don't look right in XP even when you use the common
controls manifest.

>--
>Kevin Westhead



>> The problem still exists on win2000 and even on winXP.

>.



Wed, 29 Sep 2004 04:08:48 GMT  
 Treeview 6.0 Node Tip Bug
Can you use the VB5 common controls in place of the other VB6 common
controls as well? The only thing that isn't in the VB5 version is
ImageCombo. You could implement this as a custom OCX, although admittedly
that isn't easy.

--
Kevin Westhead


Quote:
> Hi, I've been using TV 5.0 to avoid this problem, but as
> you know when I package a program, both common controls
> 6.0 (for other controls) and common controls 5.0 (for the
> TV only) have to be included with the package which in
> turn will increase the size of the package. That's whay
> I've been trying to find a fix to this bug. Thanks for the
> help :-)



Wed, 29 Sep 2004 04:22:48 GMT  
 
 [ 13 post ] 

 Relevant Pages 

1. TreeView 6.0 node tip

2. Start dragging Nodes in a TreeView (VB 6.0)

3. dragging Nodes in a TreeView (VB 6.0)

4. Treeview node check bug.

5. BUG:Treeview.Nodes.Clear method very slow with ComCtl32.DLL version 4.71.17123

6. Treeview selects node before events fire (Bug?)

7. Treeview Control Node Tooltips Bug in NT

8. treeview node count not incrementing when adding new nodes

9. treeview - Move node, insert node

10. TreeView-Move Node Between Other Nodes?

11. Copying TreeView nodes to another TreeView

12. BUG: Problems with MDAC20.Cab Shipping in VS 6.0 and VB 6.0

 

 
Powered by phpBB® Forum Software