ActiveX Doc Error 336 with AsyncRead 
Author Message
 ActiveX Doc Error 336 with AsyncRead

I have the following problem:
I have an ActiveX Document written in Visual Basic 5 with service pack 3.
It contains one command button and the following code:

Private Sub Command1_Click()
    UserDocument.AsyncRead " http://www.*-*-*.com/ ;,
vbAsyncTypeFile, "Test"
End Sub

Private Sub UserDocument_AsyncReadComplete(AsyncProp As AsyncProperty)
    If AsyncProp.PropertyName = "Test" Then
        MsgBox "File Read"
    End If
End Sub

When the page is loaded into the browser and the Command Button is clicked I
get the following error message:

Run-time error '336"
Component not correctly registered

This problem occurs with several but not all of my test machines. Some run
Windows 95 some Windows 98 some Windows NT 4.0 with Service Pack 3. All run
Internet Explorer 4.0 build 4.72.3110 or 4.72.3110.8 with Service Pack 1
installed. All machines already contain the following runtime files:

msvbvm50.dll
asycfilt.dll

If I delete these file and force downloads of the cabinets I still get the
same error. Is this a bug or am I overlooking something?
Can anyone point me in the right direction to find this problem?



Fri, 09 Mar 2001 03:00:00 GMT  
 ActiveX Doc Error 336 with AsyncRead
James,

Have you tried vbc.exe (Knowledge Base Q181854) which corrects many
"incorrectly installed components"?

Eldon Ward

Quote:

>I have the following problem:
>I have an ActiveX Document written in Visual Basic 5 with service pack 3.
>It contains one command button and the following code:

>Private Sub Command1_Click()
>    UserDocument.AsyncRead "http://myserver.com/default.htm",
>vbAsyncTypeFile, "Test"
>End Sub

>Private Sub UserDocument_AsyncReadComplete(AsyncProp As AsyncProperty)
>    If AsyncProp.PropertyName = "Test" Then
>        MsgBox "File Read"
>    End If
>End Sub

>When the page is loaded into the browser and the Command Button is clicked
I
>get the following error message:

>Run-time error '336"
>Component not correctly registered

>This problem occurs with several but not all of my test machines. Some run
>Windows 95 some Windows 98 some Windows NT 4.0 with Service Pack 3. All run
>Internet Explorer 4.0 build 4.72.3110 or 4.72.3110.8 with Service Pack 1
>installed. All machines already contain the following runtime files:

>msvbvm50.dll
>asycfilt.dll

>If I delete these file and force downloads of the cabinets I still get the
>same error. Is this a bug or am I overlooking something?
>Can anyone point me in the right direction to find this problem?



Fri, 16 Mar 2001 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. AsyncRead won't work on IE 4 client, error 336

2. UserControl.AsyncRead - runs into error 336

3. AsyncRead won't work on IE 4 client, error 336

4. Error 336 Activex component not correctly registered

5. Error 336: ActiveX component not correctly registered!

6. Error: Object server not correctly registered (Error 336)

7. Unexpected error (336)

8. VB4 Error 336

9. Object server not correctly registered (Error 336)

10. Object Server Not Correctly Registered (Error 336)

11. runtime error 336

12. error 336 - Object Server Not Correctly Registered...

 

 
Powered by phpBB® Forum Software