POST method NOT WORKING... pls help 
Author Message
 POST method NOT WORKING... pls help

Hi guys

these coupla days have been reading this newsgroups and found that a few people
have been asking the same question -
ie how the heck do we post data (ie emulate the form action=post) to a database
using vbcode.

the ultimate aim for me is to post some user data to a web database.
I guess I could use RDO but thought that the overhead would be too high.

I've tried
1)inet control MSINET.OCX- doesn't work when I used
.execute .url, "POST", "x1=bla bla bla...."

2)tried also the MSXML method as someone said. didn't work as well... just didn't
do anything and sometimes yielded errors

3)tried the webbrowser control to use the .navigate method... also doesn't work

does someone out there have a better way or can they can be specific about how to
use the POST method to work correctly???

thanks very much.

ted.



Mon, 25 Aug 2003 01:38:06 GMT  
 POST method NOT WORKING... pls help

I've attached sample code on how to accomplish this by using Win32 functions of
wininet.dll. The first half of the document are the constant and function
declarations for calling wininet.dll. The second half is my custom
subroutine "PostData" which, using the wininet.dll functions, POSTs the data
contained in the variable sData to the server/page contained in sServer/sPage. It
should all be farely self-explanatory.

I hope this helps.

Quote:
-----Original Message-----

Hi guys

these coupla days have been reading this newsgroups and found that a few people
have been asking the same question -
ie how the heck do we post data (ie emulate the form action=post) to a database
using vbcode.

the ultimate aim for me is to post some user data to a web database.
I guess I could use RDO but thought that the overhead would be too high.

I've tried
1)inet control MSINET.OCX- doesn't work when I used
..execute .url, "POST", "x1=bla bla bla...."

2)tried also the MSXML method as someone said. didn't work as well... just didn't
do anything and sometimes yielded errors

3)tried the webbrowser control to use the .navigate method... also doesn't work

does someone out there have a better way or can they can be specific about how to
use the POST method to work correctly???

thanks very much.

ted.

.

  VBPOST.txt
4K Download


Mon, 25 Aug 2003 04:27:32 GMT  
 POST method NOT WORKING... pls help
ok I've found the solution at

the other newsgroup.
xml.msxml-webrelease

the big tip here is the content-type header.
I suppose now everyone will be working on spyware...



Mon, 25 Aug 2003 04:30:39 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. .addnew method ADO does not work pls help

2. Inet control does not work with POST method ?

3. select into sql statement not working - pls help

4. NetFileClose is not working...pls help!!

5. Going insane: ApplyFilter method is NOT working, help

6. POST method doesn't work

7. POST Method not allowed

8. Find method in Ado...pls help...

9. Post to Public Folder not working

10. Large data posts not working??

11. GetChunk with POST, Why does this not work?

12. HTTP POST not working

 

 
Powered by phpBB® Forum Software