IIS App runs in VB but not when compiled? 
Author Message
 IIS App runs in VB but not when compiled?

permission.

Set to anonymous web user permission on this directory, or run web
application out of memory and make it impersonate another user..


Quote:
> I have an odd problem with a webclass application I have been developing.
> It runs well in the IDE, but after compiling it there is one particular
> function that doesn't peform the way it's supposed to.  I use this
function
> to check if a specific folder can be accessed.  The function code is as
> follows:

> *** start code block

> Dim fso as New FileSystemObject

> Public Function GetFolder(ByVal strName As String, _
>                  Optional ByRef fld As Folder = Nothing) As Boolean

>   On Error GoTo Err_Handler

>   Set fld = fso.GetFolder(fso.GetAbsolutePathName(strName))
>   GetFolder = True

>   Exit Function

> Err_Handler:
>   If Err.Number = 76 Then
>       GetFolder = False
>   End If

> End Function

> *** end code block

> The function is called within an IF statement like this:

> If cls.GetFolder(strTemp) Then
>     *** code goes here
> end if

> Again, this works just fine in Visual Basic, but when compiled it seems to
> always return false...although, this is just an assumption because after
> compiling I can't do any debugging in VB because it skips over all of my
> breakpoints.  The only solution I have to be able to debug again is to
> restart my computer.  I think there may be a problem in the registry with
> the DLL, but I really have no idea.  Any help would be greatly
appreciated.
> Thanks.



Fri, 06 Jun 2003 04:25:41 GMT  
 IIS App runs in VB but not when compiled?
I'm having a similar problem.
Please tell me how to set the web application to run out of memory?
Thank you


Quote:
> permission.

> Set to anonymous web user permission on this directory, or run web
> application out of memory and make it impersonate another user..



> > I have an odd problem with a webclass application I have been
developing.
> > It runs well in the IDE, but after compiling it there is one particular
> > function that doesn't peform the way it's supposed to.  I use this
> function
> > to check if a specific folder can be accessed.  The function code is as
> > follows:

> > *** start code block

> > Dim fso as New FileSystemObject

> > Public Function GetFolder(ByVal strName As String, _
> >                  Optional ByRef fld As Folder = Nothing) As Boolean

> >   On Error GoTo Err_Handler

> >   Set fld = fso.GetFolder(fso.GetAbsolutePathName(strName))
> >   GetFolder = True

> >   Exit Function

> > Err_Handler:
> >   If Err.Number = 76 Then
> >       GetFolder = False
> >   End If

> > End Function

> > *** end code block

> > The function is called within an IF statement like this:

> > If cls.GetFolder(strTemp) Then
> >     *** code goes here
> > end if

> > Again, this works just fine in Visual Basic, but when compiled it seems
to
> > always return false...although, this is just an assumption because after
> > compiling I can't do any debugging in VB because it skips over all of my
> > breakpoints.  The only solution I have to be able to debug again is to
> > restart my computer.  I think there may be a problem in the registry
with
> > the DLL, but I really have no idea.  Any help would be greatly
> appreciated.
> > Thanks.



Tue, 10 Jun 2003 14:08:22 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. IIS app runs compiled, but not from IDE

2. IIS app runs compiled, but not from IDE

3. Getsettings not working in compiled IIS app.

4. dcom object runs fine in vb app, fails to get created in IIS

5. Error Running Compiled VB App

6. Problems Running Compiled VB App (uses MTS componants) on another PC

7. VB DLL Runs on two IIS machines but not on Thrid

8. VB6 IIS Application won't run after compile

9. compiled VB proj exhibits run time error, but not in IDE/debug

10. Application Run in VB but not in Compiled exe

11. Win2000, IIS 5 and WebClasses -- won't run without VB running

12. running an IIS App

 

 
Powered by phpBB® Forum Software