vbscript domain calls fail since installing SRP 
Author Message
 vbscript domain calls fail since installing SRP

I have a tried and true VBScript to handle NT account management.  The
script attaches to my domain via GetObject ("WinNT://domainname"....).  It
has all worked perfectly in the past.

This past weekend the NT 4 security rollup pack (Q299444) was installed on
my workstation.
I am now unable to attach to the domain with my scripts.  When the scripts
go to attach to the domain, I get an error msg 'the network path was not
found'.

Has anyone encountered this same problem?  Any way to fix this or isolate
the problem, other than uninstalling NT 4 6a security rollup package?

TIA

Jane



Sun, 26 Sep 2004 08:14:10 GMT  
 vbscript domain calls fail since installing SRP

Quote:

> Has anyone encountered this same problem?  Any way to fix this or
> isolate the problem, other than uninstalling NT 4 6a security rollup
> package?

This is a known (withn the NGs) problem on NT4 boxes with the post sp6a SRP installed.  Uninstalling the SRP fixes the problem.  If an uninstll is not an option, then adding a domain server name into the ADS path works.

set shell = createobject("wscript.shell")
LOGONSERVER = mid(shell.Environment("PROCESS")("LOGONSERVER"),3)
username = "whatever"
adsPath = "WinNT://domainname/" _
  & LOGONSERVER & "/" _
  & username & ",user"
set oUser = GetObject(adsPath)

--
Michael Harris
Microsoft.MVP.Scripting
Seattle WA US
--



Sun, 26 Sep 2004 09:54:36 GMT  
 vbscript domain calls fail since installing SRP
Thanks for the information.  Does the NT 4 post sp6a SRP have any other
impact on scripting or are the problems only related to these domain calls?

My script is really written in vbscript, so perhaps I have addressed this
issue to the wrong newsgroup.
With regard to the code below - would it be the same for vbscript?

Thanks.



Quote:

> Has anyone encountered this same problem?  Any way to fix this or
> isolate the problem, other than uninstalling NT 4 6a security rollup
> package?

This is a known (withn the NGs) problem on NT4 boxes with the post sp6a SRP
installed.  Uninstalling the SRP fixes the problem.  If an uninstll is not
an option, then adding a domain server name into the ADS path works.

set shell = createobject("wscript.shell")
LOGONSERVER = mid(shell.Environment("PROCESS")("LOGONSERVER"),3)
username = "whatever"
adsPath = "WinNT://domainname/" _
  & LOGONSERVER & "/" _
  & username & ",user"
set oUser = GetObject(adsPath)

--
Michael Harris
Microsoft.MVP.Scripting
Seattle WA US
--



Mon, 27 Sep 2004 00:30:47 GMT  
 vbscript domain calls fail since installing SRP

Quote:

> Thanks for the information.  Does the NT 4 post sp6a SRP have any other
> impact on scripting or are the problems only related to these domain calls?

This is the only SRP related problem that I personally know of.  Of course I have since moved to Win2000 on all the boxes I have access to.

Quote:
> My script is really written in vbscript, so perhaps I have addressed this
> issue to the wrong newsgroup.
> With regard to the code below - would it be the same for vbscript?

Umm... The posted code *is* VBScript ;-)...

--
Michael Harris
Microsoft.MVP.Scripting
Seattle WA US
--



Mon, 27 Sep 2004 00:56:45 GMT  
 vbscript domain calls fail since installing SRP
ok,  I guess that I asked for that  :)




Quote:
> Thanks for the information.  Does the NT 4 post sp6a SRP have any other
> impact on scripting or are the problems only related to these domain
calls?

This is the only SRP related problem that I personally know of.  Of course I
have since moved to Win2000 on all the boxes I have access to.

Quote:
> My script is really written in vbscript, so perhaps I have addressed this
> issue to the wrong newsgroup.
> With regard to the code below - would it be the same for vbscript?

Umm... The posted code *is* VBScript ;-)...

--
Michael Harris
Microsoft.MVP.Scripting
Seattle WA US
--



Mon, 27 Sep 2004 03:51:54 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. After installing SRP certain Domain interegations do not work with ADSi

2. Problem with GetObject after installing NT Security Rollup Package (SRP)

3. ADSI call works in vbscript fails in jscript

4. ADSI call works in vbscript fails in jscript

5. ADSI call works in vbscript fails in jscript

6. Cross-domain LDAP referrals fail

7. Cross-domain LDAP referrals fail in the same forest

8. Setting property document.domain fails with Invalid Argument

9. XP Install 5.6 (revised) fails

10. wshPrint & wshAdmin fail to install printer drivers

11. Install Fonts in domain!

12. How to remotely install a software on all machines of a Domain

 

 
Powered by phpBB® Forum Software