Running WSH on NT 4.0 
Author Message
 Running WSH on NT 4.0

WSH & ADSI must be installed on the client that is mapping the drive,
AFAIK it doesn't need to be on the server.

HTH

Quote:

> I get "the specified device name is invalid
> WshNetwork.MapNetworkDrive"
> whenever I try to run the .MapNetworkDrive object.  ADSI 2.5 is
> installed on the server and so is the newest version of WSH.  Any
> Suggestions???



Tue, 18 Jun 2002 03:00:00 GMT  
 Running WSH on NT 4.0

You don't need ADSI to map network drives.  It sounds more like you just aren't passing a valid argument to the MapNetworkDrive method.  I'm assuming you're creating an instance using something like (straight from the example in the documentation):

Set WshNetwork = WScript.CreateObject("WScript.Network")
WshNetwork.MapNetworkDrive "Z:", "\\Server\Share"

--
Michael Harris


  WSH & ADSI must be installed on the client that is mapping the drive,
  AFAIK it doesn't need to be on the server.

  HTH


  >
  > I get "the specified device name is invalid
  > WshNetwork.MapNetworkDrive"
  > whenever I try to run the .MapNetworkDrive object.  ADSI 2.5 is
  > installed on the server and so is the newest version of WSH.  Any
  > Suggestions???



Tue, 18 Jun 2002 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. WSH on NT 4.0 Server without IE 4.0 (5.0)

2. How to run VBSCRIPTS on NT 4.0?

3. Problem: WSHShell.run returns ErrCode under NT 4.0

4. Can't run an NT 4.0 VBScript at Startup -- Event ID 1000

5. why doesn't this script run on NT 4.0

6. How to get a list of running processes in NT 4.0

7. NT 4.0 does not understand WSH

8. Security Concerns for implementing WSH in a Windows NT 4.0 environment

9. NT 4.0 Event Log management from WSH

10. WSH works with NT 4.0

11. WSH is not working under NT 4.0

12. Enabling Remote Access for WSH on Windows NT 4.0 SP6

 

 
Powered by phpBB® Forum Software