Suppressing Form Load Event at Design Time 
Author Message
 Suppressing Form Load Event at Design Time

Based on my experience, it seems clear to me that the form_load event occurs
when you open the form in design mode in the IDE. (If this is not the case
kindly explain to me why I get a null error refering to other stuff in my
app when I open the form in design.)

At any rate is there an attribute or other means to suppress the form_load
event at design time.

As I said at a recent MS seminar: "This ain't your father's BASIC." :-))))

Regards
Al Christoph



Sat, 27 Mar 2004 19:04:58 GMT  
 Suppressing Form Load Event at Design Time
Could you be a bit more specific?  The Load event doesn't "fire" in design
mode.  What does the null error you are receiving refer to?

Jacob


Quote:
> Based on my experience, it seems clear to me that the form_load event
occurs
> when you open the form in design mode in the IDE. (If this is not the case
> kindly explain to me why I get a null error refering to other stuff in my
> app when I open the form in design.)

> At any rate is there an attribute or other means to suppress the form_load
> event at design time.

> As I said at a recent MS seminar: "This ain't your father's BASIC." :-))))

> Regards
> Al Christoph



Sun, 28 Mar 2004 00:28:24 GMT  
 Suppressing Form Load Event at Design Time
I must be smoking something. This morning I was able to repeatedly get a
message to the effect that a null has been encountered when ever I opened in
design mode any form that inherited a form that was referring to a global
object in its load event. It did not make the least bit sense to me, but
when i stuck in the statement

if globalObject is nothing then exit sub

at the beginning of the parent form's load event then everything was fine.
That is when i double clicked on the form in the the solution explorer the
form opened. Without the above line instead of the form view I got a view
with an message that the form could not be opened until the problem was
fixed and then a message to the effect that a null had been encountered.

I am working with Version 7.0.9254 and have service pack 2 installed.

So i'm still looking for an explanation of what was going wrong.

PS Thanks to Jim Baker for some excellent help he gave me on two other
problems. I have a brand new PC with WinXP - Home!!! preinstalled and don't
have OE configured yet (don't ask:-)) so I'm thanking him this way.

Regards,
Al


Quote:
> Based on my experience, it seems clear to me that the form_load event
occurs
> when you open the form in design mode in the IDE. (If this is not the case
> kindly explain to me why I get a null error refering to other stuff in my
> app when I open the form in design.)

> At any rate is there an attribute or other means to suppress the form_load
> event at design time.

> As I said at a recent MS seminar: "This ain't your father's BASIC." :-))))

> Regards
> Al Christoph



Sun, 28 Mar 2004 01:48:02 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Load time VB-forms (design time)

2. Form Load & Suppressing Control Firing Events

3. Creating forms at run time, not design time.

4. Assign a treeview at design run time to other at design time

5. Problem with Load event and dervied contol in design mode

6. Help: Design-Time SubMenu Creation (w/Load Method)

7. WebBrowser Control Automatically Loads Page in Design/Run-Time

8. Sizable form with resize event suppressed

9. Add Event Code On form Load Event

10. Paint Event different design vs run-time?

11. design-time ActiveX events

12. click events with design-time listboxes

 

 
Powered by phpBB® Forum Software