VBScript Problem in Visual Interdev 6.0 
Author Message
 VBScript Problem in Visual Interdev 6.0

Hi,
    I am teaching myself Visual Interdev 6.0  I am using Visual Studio
Professional.  When I try and do VB Script I always recieve and error
message that says -
"An error has occurred in the script on this page"  It then shows the line
and column number of the offending command.  It is always after the first
command of the function.  The dialog box says it expects a ";".
    When I try the same function in Visual Basic 6.0 Pro Edition it works
fine.

Does anyone know why Visual Studio does not like the code?  FYI I haven't
had any problems with JavaScript.

Thanks
Drew



Sun, 06 May 2001 03:00:00 GMT  
 VBScript Problem in Visual Interdev 6.0
Not seeing your code it looks as if your langauge is set to JScript rather
than VBScript so the JScript compiler complains because you're feeding it
VBScript.

Post the offending file and we'll take a look

Andrew


Quote:
>Hi,
>    I am teaching myself Visual Interdev 6.0  I am using Visual Studio
>Professional.  When I try and do VB Script I always recieve and error
>message that says -
>"An error has occurred in the script on this page"  It then shows the line
>and column number of the offending command.  It is always after the first
>command of the function.  The dialog box says it expects a ";".
>    When I try the same function in Visual Basic 6.0 Pro Edition it works
>fine.

>Does anyone know why Visual Studio does not like the code?  FYI I haven't
>had any problems with JavaScript.

>Thanks
>Drew



Sun, 06 May 2001 03:00:00 GMT  
 VBScript Problem in Visual Interdev 6.0
Here is the code for what I was doing

<HTML>
<HEAD>
<META name=VI60_defaultClientScript content=VBScript>
<META NAME="GENERATOR" Content="Microsoft Visual Studio 6.0">
<TITLE></TITLE>
<SCRIPT ID=clientEventHandlersVBS LANGUAGE=vbscript>
<!--

function btnVBScript_onclick() {
MsgBox "Hello World!", 0, "VBScript"

Quote:
}

//-->
</SCRIPT>
</HEAD>
<BODY>

<P>&nbsp;</P>

<P>&nbsp;</P>

<P>&nbsp;</P>

<P><INPUT id=btnVBScript name=btnVBScript type=button value="Use VBScript"
LANGUAGE=vbscript onclick="return btnVBScript_onclick()"></P>

</BODY>
</HTML>

I had to change language to vbscript manually.  It still doesn't work.
Where else to I need to set these properties?
The book I am using says that a person can use both javascript and vbscript
on the same page.  Is this true?

Drew


Quote:
>Not seeing your code it looks as if your langauge is set to JScript rather
>than VBScript so the JScript compiler complains because you're feeding it
>VBScript.

>Post the offending file and we'll take a look

>Andrew



>>Hi,
>>    I am teaching myself Visual Interdev 6.0  I am using Visual Studio
>>Professional.  When I try and do VB Script I always recieve and error
>>message that says -
>>"An error has occurred in the script on this page"  It then shows the line
>>and column number of the offending command.  It is always after the first
>>command of the function.  The dialog box says it expects a ";".
>>    When I try the same function in Visual Basic 6.0 Pro Edition it works
>>fine.

>>Does anyone know why Visual Studio does not like the code?  FYI I haven't
>>had any problems with JavaScript.

>>Thanks
>>Drew



Sun, 06 May 2001 03:00:00 GMT  
 VBScript Problem in Visual Interdev 6.0

You are using JavaScript notation for functions.  Try using:

 SUB btnVBScript_onClick()
    MsgBox "Hello World!", 0, "VBScript"
END SUB

instead.  

<PAIN IN MY A$$>
OE5 Beta picks up <HTML> tags in a text message, and interprets what's inside as HTML.  All of the broken code people post in these newsgroups try to run inside OE5.  I can't wait until people start posting bugs that crash the browser = crash my email client.
</PAIN>

<SUPPOSE I CAN'T COMPLAIN... I AM RUNNING A BETA>
But I'm really only running it because IE5 Beta (very cool.. check out HTA's) broke OE4's spell checker.
</SUPPOSE>
------------------------
John T. Spivey

  Here is the code for what I was doing




Mon, 07 May 2001 03:00:00 GMT  
 VBScript Problem in Visual Interdev 6.0

Thanks for everyone's help.  It really does help when you use VB Script syntax as well as selecting the object to be VB text before inserting the code for it.

Drew


    You are using JavaScript notation for functions.  Try using:

    SUB btnVBScript_onClick()
        MsgBox "Hello World!", 0, "VBScript"
    END SUB

    instead.  

    <PAIN IN MY A$$>
    OE5 Beta picks up <HTML> tags in a text message, and interprets what's inside as HTML.  All of the broken code people post in these newsgroups try to run inside OE5.  I can't wait until people start posting bugs that crash the browser = crash my email client.
    </PAIN>

    <SUPPOSE I CAN'T COMPLAIN... I AM RUNNING A BETA>
    But I'm really only running it because IE5 Beta (very cool.. check out HTA's) broke OE4's spell checker.
    </SUPPOSE>
    ------------------------
    John T. Spivey

        Here is the code for what I was doing




Mon, 07 May 2001 03:00:00 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. Problems with visual interdev 6.0

2. Visual Interdev 6.0 -> Next problem

3. Problem in using Crystal Report Design Time Control in Visual Interdev 6.0

4. Visual Interdev 6.0 -> Next problem

5. Question: Debugging scripts with MS Visual interDev 6.0 on Personal Web Server

6. Question: Debugging scripts with MS Visual interDev 6.0 on Personal Web Server

7. The Visual InterDev 6.0 Scripting Object Moderequires JSCRIPT.DLL

8. Question: Debugging scripts with MS Visual interDev 6.0 on Personal Web Server

9. Visual InterDev 6.0 bug???

 

 
Powered by phpBB® Forum Software