Tk v8.3.4: Application initialization failed 
Author Message
 Tk v8.3.4: Application initialization failed

I've built Tk v8.3.4 such that the prefix and exec-prefix directories are
different.  Now wish8.3 will load but the following error is displayed.
Help?

Application initialization failed: missing close-bracket



Sat, 24 Jul 2004 03:31:19 GMT  
 Tk v8.3.4: Application initialization failed

Quote:

> I've built Tk v8.3.4 such that the prefix and exec-prefix directories are
> different.  Now wish8.3 will load but the following error is displayed.
> Help?

> Application initialization failed: missing close-bracket

1) The initialization sequence is quite OS-dependent.  What OS are you
   working on?  Do you have the environment variables TK_LIBRARY and/or
   TCL_LIBRARY set to anything?

2) It's more useful for you to report bugs like this to the tktoolkit
   project at SourceForge where developers are more certain to see them
   and act on them.

        http://sf.net/projects/tktoolkit/

--
| Don Porter          Mathematical and Computational Sciences Division |

| http://math.nist.gov/~DPorter/                                  NIST |
|______________________________________________________________________|



Sat, 24 Jul 2004 06:05:50 GMT  
 Tk v8.3.4: Application initialization failed

Quote:


> > I've built Tk v8.3.4 such that the prefix and exec-prefix directories are
> > different.  Now wish8.3 will load but the following error is displayed.
> > Help?

> > Application initialization failed: missing close-bracket

> 1) The initialization sequence is quite OS-dependent.  What OS are you
>    working on?  Do you have the environment variables TK_LIBRARY and/or
>    TCL_LIBRARY set to anything?

> 2) It's more useful for you to report bugs like this to the tktoolkit
>    project at SourceForge where developers are more certain to see them
>    and act on them.

>         http://sf.net/projects/tktoolkit/

This is actually a bug on my part.  I modified the generic/tclInitScript.h
and library/auto.tcl scripts to search a specific relative directory to find
the Tcl8.3 library.  In thr process, I forgot to add close-bracket.  Thank
you for help.  I'm sorry it was due to my carelessness.


Sat, 24 Jul 2004 10:26:27 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Application initialization failed: Can't find a usable tk.tcl in the following directories:

2. option -h retuirns Application initialization failed

3. application initialization failed: not installed properly

4. tclsh getting - application-specific initialization failed: $msg

5. application-specific initialization failed: $msg?

6. tk v8.4a1 (and v8.3.1) fails test color-2.6 under both CDE and OW

7. embed application in a tk frame => failed

8. multithreaded embedded python fails during initialization

9. initialization failed .... tcl_findLibarary

10. Question: what's app-specific initialization failed:msg

11. TclX6.3-p1 bug => Picasso initialization failing

12. incrTcl v3.2 does not install with Tcl/Tk v8.3.1

 

 
Powered by phpBB® Forum Software