Install tcl 8.4 error, Can't find a usable init.tcl in the following directories 
Author Message
 Install tcl 8.4 error, Can't find a usable init.tcl in the following directories

I build tcl 8.4.10 on Solaris 8, compile ok, but get error when running
"make test"
I run:

  configure --prefix=/users/xucai --exec-prefix=/users/xucai
--enable-shared --enable-gcc   //ok
  make          //ok
   make test  // this step failed.

and get following error:

LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}; export LD_LIBRARY_PATH; \
TCL_LIBRARY="/users/xucai/src/tcl8.4.10/library"; export TCL_LIBRARY; \
./tcltest ./../tests/all.tcl
application-specific initialization failed: Can't find a usable
init.tcl in the following directories:
    /users/xucai/src/tcl8.4.10/library /users/xucai/lib/tcl8.4
/users/xucai/src/tcl8.4.10/library /users/xucai/src/tcl8.4.10/tcl8.4
/users/xucai/src/tcl8.4.10/lib/tcl8.4 /users/xucai/src/lib/tcl8.4
/users/xucai/src/tcl8.4.10/library /users/xucai/src/library
/users/xucai/src/tcl8.4.10/library /users/xucai/tcl8.4.10/library
/users/xucai/lib/tcl8.4

/users/xucai/src/tcl8.4.10/library/init.tcl: can't read "::auto_path":
no such variable
can't read "::auto_path": no such variable
    while executing
"lsearch -exact $::auto_path $Dir"

what does it mean ? who can help  ?

thx.



Sat, 26 Jul 2008 16:21:59 GMT  
 Install tcl 8.4 error, Can't find a usable init.tcl in the following directories

Quote:

> I build tcl 8.4.10 on Solaris 8, compile ok, but get error when running...

Q) Why are you choosing to build from source, when ActiveState offers
   pre-built ActiveTcl binaries for Solaris as a free download?

        <URL: http://www.activestate.com/Products/ActiveTcl/ >

Q) If you insist on building from source, why aren't you making use of
   the latest sources released, version 8.4.12 ?

        <URL: http://sourceforge.net/project/showfiles.php?
        group_id=10894&package_id=10452&release_id=375153 >

If you choose one of those paths, you're more likely to find folks
willing to help if you still run into trouble.

--
| Don Porter          Mathematical and Computational Sciences Division |

| http://math.nist.gov/~DPorter/                                  NIST |
|______________________________________________________________________|



Sat, 26 Jul 2008 23:49:18 GMT  
 Install tcl 8.4 error, Can't find a usable init.tcl in the following directories
Don,
     Thx for your reply.

1,  I think ActiveTcl binaries for Solaris will work. But I just wanna
build tcl from source.

2,  Actually I build Tcl 8.4.12 first, and it failed with same error.

BTW, I try to build it on another Solaris box, and it's OK.
But I don't know why it failed on the first box & how to fix it. What
does the error message mean ?  

Jeff.



Sun, 27 Jul 2008 13:18:15 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. TclError: Can't find a usable init.tcl in the following directories:

2. Tcl install -- can't find init.tcl

3. TclError: Can't find a usable init.tcl

4. Can't find a usable init.tcl ...

5. Application initialization failed: Can't find a usable tk.tcl in the following directories:

6. cannot find a usable init.tcl???

7. Can't find a usable init.tcl ... Tcl wasn't installed correctly

8. "Can't find a usable init.tcl in the following directories" when space in file path

9. Can't find a usable tk.tcl

10. more details: Tk_Init in C can't find a usable tk.tcl

11. ruby can't find init.tcl

12. Tcl8.3 Problem: Can't find correct init.tcl file

 

 
Powered by phpBB® Forum Software