can't pass environment vars using exec 
Author Message
 can't pass environment vars using exec

Hi

I am writing a tcl/tk app with several modules contained in seperate
files. Every file can be run as an independent program, no problem.

The trouble I'm having is that when I launch a tk script file from
another script using exec, the "child" script dies.  Seems it can't find
the library paths.  

I have tried setting the "tk_library" variable in each of the files
and this has no effect.  The "child" script doesn't have the env array
defined (I get nothing when I try to print it out), but the "parent"
script has no such problem.

The other "wierd" thing is that everything works great on my linux box,
but I get this problem on the HP735s at work.

I have been using the following code to launch my subprocess(es):

button .b <bunch -o- stuff> -command {exec ~/workspace.tcl $tk_library &}

I have tried alot of other things as well, but nothing seems to have
any effect (not even a bad effect :-) ).  

Any ideas, I'm fresh out.
--
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Gregg Pulley                            "The first step toward global

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=



Fri, 03 Apr 1998 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Using CGI module with 'canned queries'

2. Using exec in DOS/Windows environment

3. Using 'exec' in subroutines

4. Using '*'in exec command on UNIX

5. How to pass arguments to program been exec'ed

6. Problem: args don't pass at exec (tkcvs)

7. It's not bad canned meat...

8. It's not bad canned meat...

9. It's not bad canned meat...

10. It's not bad canned meat...

11. method vars environment support missing

12. Create Environment Vars

 

 
Powered by phpBB® Forum Software