Inconsistent file command behaviour on WinXP 
Author Message
 Inconsistent file command behaviour on WinXP

Hi Tcl'ers

Using the file command on the Windows special files "pagefile.sys" or
"hiberfil.sys"
shows inconsistent behaviour:

% dir /AS

17.04.2004  18:11               194 boot.ini
29.08.2002  22:00             4.952 bootfont.bin
21.05.2004  16:31       535.875.584 hiberfil.sys
23.09.2003  13:23                 0 IO.SYS
23.09.2003  13:23                 0 MSDOS.SYS
29.08.2002  22:00            47.580 NTDETECT.COM
29.08.2002  22:00           235.296 ntldr
21.05.2004  16:30       805.306.368 pagefile.sys
17.04.2004  19:25    <DIR>          RECYCLER
17.04.2004  18:11    <DIR>          System Volume Information

% file exists pagefile.sys
0

% file attributes pagefile.sys
could not read "pagefile.sys": permission denied

% file mtime pagefile.sys
could not read "pagefile.sys": no such file or directory

% info patchlevel
8.4.5
% pwd
C:/

The "glob -type hidden" command as well as "file attribute" see these files,
whereas other file subcommands like "exists" or "mtime" claim, these files
do not exists.

Platform is XP Home SP1, Active Tcl 8.4.5.

Is this a known feature/bug ??

Thanks for your help,

Paul



Wed, 08 Nov 2006 03:47:21 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. lreplace command inconsistent behaviour

2. Inconsistent Browse/VCR behaviour

3. Strange inconsistent behaviour from OS/2 REXX exec

4. Inconsistent network behaviour

5. slicing and parallel assignment: inconsistent behaviour??

6. Inconsistent behaviour of tab stops.

7. Inconsistent include/lib behaviour

8. Inconsistent behaviour between SunOS 4.1.3U1 and Solaris 2.5.1 (x86 and Sparc)

9. Inconsistent tk_getOpenFile Behaviour

10. dde command semantics inconsistent with Tk

11. Slow "recording" on winXP Command

12. MSWLogo 6.4h - setfont command fails - WinXP Pro

 

 
Powered by phpBB® Forum Software