Tk with QT app doesn't work 
Author Message
 Tk with QT app doesn't work

Hi!

I've tried to run Tk in QT application. I've implemented TCL interpreter in
this appliaction so far, but I still don't know why Tk doesn't work :(
I execute:

Tcl_Init(same_interp); // this one works, TCL works.

and just after that:

Tk_Init(here_my_interp);

it returns TCL_OK, but I can't see any window.
I've tried to check some things and I can say, that '.' window exists -
winfo said that, but more interesting is, that 'winfo ismapped .' returns 0
:( I've tried to build new toplevel window, but result was the same.

I guess that 'ismapped = 0' is the reason, but how to fix it?
--
Pozdrawiam (Greetings).
Googie



Sat, 15 Jul 2006 21:16:32 GMT  
 Tk with QT app doesn't work

Quote:

> I've tried to run Tk in QT application. I've implemented TCL interpreter in
> this appliaction so far, but I still don't know why Tk doesn't work :(
> I execute:

> Tcl_Init(same_interp); // this one works, TCL works.

> and just after that:

> Tk_Init(here_my_interp);

> it returns TCL_OK, but I can't see any window.
> I've tried to check some things and I can say, that '.' window exists -
> winfo said that, but more interesting is, that 'winfo ismapped .' returns 0

What are you calling to allow Tk to service its event loop?

--
| Don Porter          Mathematical and Computational Sciences Division |

| http://math.nist.gov/~DPorter/                                  NIST |
|______________________________________________________________________|



Sat, 15 Jul 2006 22:25:16 GMT  
 Tk with QT app doesn't work

Quote:


>> I've tried to run Tk in QT application. I've implemented TCL interpreter
>> in this appliaction so far, but I still don't know why Tk doesn't work :(
>> I execute:

>> Tcl_Init(same_interp); // this one works, TCL works.

>> and just after that:

>> Tk_Init(here_my_interp);

>> it returns TCL_OK, but I can't see any window.
>> I've tried to check some things and I can say, that '.' window exists -
>> winfo said that, but more interesting is, that 'winfo ismapped .' returns
>> 0

> What are you calling to allow Tk to service its event loop?

Ah :( Right... Event loop. Thx.
--
Pozdrawiam (Greetings).
Googie


Sun, 16 Jul 2006 00:05:44 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. BLT installs but doesn't work, and TkTable doesn't build

2. Main Window doesn't show up in my tk app

3. tk app doesn't update screen under load

4. Tkinter doesn't work with beta tk/tcl

5. Tk make test doesn't completely work

6. XIM patches for Tcl/Tk 8.3.0 doesn't work

7. tcl/tk doesn't work under SunOS

8. Setting bit_gravity of a default tk window doesn't work

9. Loading TK-4.1 under TCL-7.5 doesn't work

10. XF 2.3 and Tcl7.4/Tk 4.0 doesn't work

11. EAI works (or doesn't work) differently under different platforms

12. tkman works/doesn't work [hpux9]

 

 
Powered by phpBB® Forum Software