Loading TK-4.1 under TCL-7.5 doesn't work 
Author Message
 Loading TK-4.1 under TCL-7.5 doesn't work

Hi,

I compiled tk-4.1-b3 and tcl-7.5-b3.
tclsh and wish run fine, but when I tested dynamic loading,
I found that loading tk in tclsh doesn't work properly:

[23] tclsh

Quote:
> label

Error: invalid command name: "label"

Quote:
> load libtk4.1.so
> label .a -text Hello
> pack .a

works, but doesn't display anything!!!
I.e. the library is loaded properly, I can issue all the
tk commands, which were not present before loading, but
hte window doesn't display.

What went wrong? Thanx in advance for any help


(This line was left blank intentionally)



Tue, 29 Sep 1998 03:00:00 GMT  
 Loading TK-4.1 under TCL-7.5 doesn't work
Quote:

>> load libtk4.1.so
>> label .a -text Hello
>> pack .a

>works, but doesn't display anything!!!
>I.e. the library is loaded properly, I can issue all the
>tk commands, which were not present before loading, but
>hte window doesn't display.

This is because the event loop in Tcl doesn't interact with
Tk properly yet.  If you add 'update idletasks', the label
will appear.

For proper event loop interaction look for the 'plus-patches'
in the archives and you may have to wait for the final
7.5/4.1 releases too.

--
    -********* *-
   -*  Vince  *-
  -* *********-

<http://www.fas.harvard.edu/~darley/>



Tue, 29 Sep 1998 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Tkinter doesn't work with beta tk/tcl

2. XIM patches for Tcl/Tk 8.3.0 doesn't work

3. tcl/tk doesn't work under SunOS

4. C4 Gold - File Loaded Combo Update Doesn't work

5. load command doesn't works

6. BLT installs but doesn't work, and TkTable doesn't build

7. tk app doesn't update screen under load

8. pkgIndex.tcl for Itcl doesn't load Itcl in vanilla wish

9. Tcl Shell doesn't refer to registry entry when loading

10. Tk with QT app doesn't work

11. Tk make test doesn't completely work

12. Setting bit_gravity of a default tk window doesn't work

 

 
Powered by phpBB® Forum Software