can not build blt2.4z with tcl/tk8.4.12 on AIX 5.2? 
Author Message
 can not build blt2.4z with tcl/tk8.4.12 on AIX 5.2?

I am using Blt2.4z which is built with tcl/tl8.4.12 on AIX now.

I got such warning as

"bltCanvEps.c", line 1689.5: 1506-196 (W) Initialization between types
"int(*)(struct Tcl_Interp*,struct Tk_Canvas_*,struct
Tk_Item*,int,struct Tcl_Obj* const*)" and "int(*)(struct
Tcl_Interp*,struct Tk_Canvas_*,struct Tk_Item*,int,unsigned char**)" is
not allowed.
"bltCanvEps.c", line 1691.5: 1506-196 (W) Initialization between types
"int(*)(struct Tcl_Interp*,struct Tk_Canvas_*,struct
Tk_Item*,int,struct Tcl_Obj* const*,int)" and "int(*)(struct
Tcl_Interp*,struct Tk_Canvas_*,struct Tk_Item*,int,unsigned
char**,int)" is not allowed.
"bltCanvEps.c", line 1692.5: 1506-196 (W) Initialization between types
"int(*)(struct Tcl_Interp*,struct Tk_Canvas_*,struct
Tk_Item*,int,struct Tcl_Obj* const*)" and "int(*)(struct
Tcl_Interp*,struct Tk_Canvas_*,struct Tk_Item*,int,unsigned char**)" is
not allowed.

Though I got bltwish24 now. While it can not be executed on AIX box.

Quote:
>bltsh24

Illegal instruction (core dumped)
Quote:
>bltwish24

Illegal instruction (core dumped)

So currently Blt2.4z can not work with Tcl/Tk 8.4.12?



Sun, 28 Sep 2008 17:41:35 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Problems when building BLT2.4u for Tcl/Tk8.4a3

2. Problems when building tk8.4.12 using MinGW

3. black background in BLT2.4z graph snapshot

4. patched BLT2.4z binaries for Win

5. Errors building tk8.2.0 on Aix

6. BLT2.4u with tcl/tk8.3.3, compatibility 8.3.2 and 8.3.3

7. BLT2.4 with Tcl/Tk8.0 called from C

8. OraTcl w/ AIX 5.2 and Oracle 9.2

9. Compiling Expect on AIX 5.2 ML1

10. AIX porting problem - cannot build libtcl8.3.so - Linux AIX Toolkit

11. Harbour build 12

12. It's not bad canned meat...

 

 
Powered by phpBB® Forum Software