exec, Windows 95 and Dos tools 
Author Message
 exec, Windows 95 and Dos tools

I'm running the most recent release (b2) of Tcl/Tk on a Windows 95 PC.
I'm having trouble with exec and some GNU ports of UNIX programs.

The problems seem to occur only when I don't dump the results
into files with the '>' operator, that is, when tclsh and wish
try to read from the pipe, and the child program has to write to
the pipe.  

When I run rlog and other RCS programs from wish, wish blocks on the
pipe and never finishes. It seems to work when I redirect the results
o files, because then it isn't reading from the pipe. Isn't Tcl
supposed to be smart about not blocking when reading from command
pipes?

On the other hand, tclsh works with the RCS programs.

When I run the Unix-like programs (ls, which, cat, etc.), wish fails
like the above and blocks on the pipe. But when run with tclsh, the
child programs fail miserably. I get the {*filter*} DOS errors:

General failure reading device LP&?
Abort, Retry, Fail?

This suggests that the Unix tools don't work when they don't have a
console. Is this a Tcl problem - is it not creating the process
correctly? Or is it a problem with the port of the UNIX tools?
How should I change the tools so that they work with wish and
tclsh?

Also, it seems that many people that write DOS tools write output to
stderr instead of stdout. Why do they do this?



Sat, 22 Aug 1998 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. ADA'95 Compilers for Windows 95 and MS-DOS

2. Running Fortran application as a DOS Windows under Windows 3.1 or 95

3. Exec and sockets on Windows 95

4. Exec does not work under Windows 95?

5. exec, Windows 95, and Tcl Plugin

6. Using "exec" under Windows 95/NT

7. exec in Windows 95

8. race condition, exec, Windows 95

9. Q: "exec" in Windows 95

10. exec in Windows 95

11. New Release of Free Ada 95 Compiler and Tools for DOS

12. New Release of Free Ada 95 Compiler/Tool Kit for DOS

 

 
Powered by phpBB® Forum Software