Problems with running Expect script on AIX 4.x (works fine on HP-UX 10.x) 
Author Message
 Problems with running Expect script on AIX 4.x (works fine on HP-UX 10.x)

Hi!  I've got an Expect script that works just fine on HP-UX 10.x, but
now I'm trying to run it on AIX 4.x, and I seem to have a problem using
functions with Expect on AIX.  See the following excerpt (sorry I can't
provide the entire listing) from my script:

./setpass[56]: proc:  not found.
./setpass[57]: send_user:  not found.
./setpass[58]: send_user:  not found.
./setpass[59]: send_user:  not found.
./setpass[60]: send_user:  not found.
./setpass[61]: send_user:  not found.
./setpass[62]: send_user:  not found.
./setpass[63]: send_user:  not found.

If anyone has any ideas as to why this might be, I would appreciate any
recommendations/suggestions.  Thanks.

        Ju

---------- excerpt of my script

#******************
# *** FUNCTIONS ***
#******************
proc usage {} {
   send_user "Usage: setpass \[username\] \[Machine_Name]\n"
   send_user "Options:\n"
   send_user "   -h          display this text\n"
   send_user "   -help       display this text\n"
   send_user "   username    the username of the user requiring a
password reset\n"
   send_user "   machine     the machine that updates should take place
on\n"
   send_user "\n"
   exit 1

Quote:
}

#*******************************************************************************
# MAIN PROGRAM
#*******************************************************************************
# main()
...


Sat, 26 May 2001 03:00:00 GMT  
 Problems with running Expect script on AIX 4.x (works fine on HP-UX 10.x)


:Hi!  I've got an Expect script that works just fine on HP-UX 10.x, but

:./setpass[56]: proc:  not found.

The behavior shown, to me, indicates that instead of using expect the
script you have is being fed to either /bin/sh, /bin/csh, or some other
similar scripting engine.

Check the first lines of your script and make sure they start up an
expect interpreter, and that you have such an interpreter compiled on
the new platform.

--

<*> O- <URL: http://www.purl.org/NET/lvirden/>
Unless explicitly stated to the contrary, nothing in this posting
should be construed as representing my employer's opinions.



Sun, 27 May 2001 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. tcl script does on expect statement only when run as daemon on HP-UX

2. Tcl/Tk running on HP-UX 10.x

3. Problem with busy on BLT2.4o with Tcl8.3 on HP-UX 10

4. VRML viewer/plugin for HP-UX 10.X

5. Dynamic loading on HP-UX 10 (yet again)

6. Shared libraries under HP/UX 10

7. Gnu CL for Hp Ux 10

8. ISO chars in text widget on HP-UX 10

9. Bug (sorta) when linking to libtk under HP-UX 10.*

10. Help with Elk on HP 425t running HP-UX 8.0

11. CProlog for a HP 9000 running HP-UX

12. Tcl script works fine under Unix but problems in MS-Windows

 

 
Powered by phpBB® Forum Software