cannot run expect script under cron 
Author Message
 cannot run expect script under cron

I'm really stuck on this one ... any help would be appreciated.

I'm using expect 4.8 under SunOS 4.1.1.  I have an expect script that telnets
out and does a few things on a remote system.  When run interactively, it
works fine.  But under cron, it dies with the error message "invalid spawn
id (0)", and for the life of me I can't figure out why.  I saw the note
about telnet{*filter*} if the term enviroment variable isn't set, but I made
sure it was.  Does anyone else have any ideas?

--Ken



Tue, 28 May 1996 00:32:02 GMT  
 cannot run expect script under cron
   I'm using expect 4.8 under SunOS 4.1.1.  I have an expect script that telnets
   out and does a few things on a remote system.  When run interactively, it
   works fine.  But under cron, it dies with the error message "invalid spawn
   id (0)", and for the life of me I can't figure out why.  I saw the note
   about telnet{*filter*} if the term enviroment variable isn't set, but I made
   sure it was.  Does anyone else have any ideas?

Probably you have an "expect_before" or "_after".  These read from
standard input (i.e., spawn id 0) by default.  Since the standard
input doesn't exist in the cron environment, Expect complains.  Fix
your expect_before statement.

Don



Tue, 28 May 1996 14:28:51 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. trouble running an expect script in cron versus command line

2. trouble running an Expect script from cron

3. Running expect scripts from cron..?

4. expect: problems running script from CRON

5. Problems running expect script in the background/from cron

6. Running EXPECT script through cron

7. problem running expect script via cron

8. Running a cron job in SFTP using Expect

9. expect script doesn't work with cron - please help

10. expect running from cron

11. cron and expect script

12. Still problems running script from cron

 

 
Powered by phpBB® Forum Software