WPY under Windows95... 
Author Message
 WPY under Windows95...

Folks,

I just installed WPY from ftp.python.org (I'm running Python1.4 with
Tk4.2/Tcl7.6 libraries installed).
I'm just wondering... When I saw WPY documentation (readme) I assumed WPY
will allow native look-n-feel portable applications between Unix/Tk and
Win32...
But if I run the examples provided with WPY under Win95, they appear with a
Tk look-n-feel, not a native Win95 look-n-feel...
Am I making a fool out of myself, or is it the way it's supposed to work ?
I'd like to write a small GUI application, with a Windows look-n-feel when
running under Windows and a Tk look-n-feel when running on Unix....
Please explain !
Thx

Jerome



Fri, 31 Mar 2000 03:00:00 GMT  
 WPY under Windows95...

----------

Quote:

> But if I run the examples provided with WPY under Win95, they appear with
a
> Tk look-n-feel, not a native Win95 look-n-feel...

There are two wpy implementations... one under MFC and one under
Tk.  If you are using the Tk one (since you installed Tk) it will have
a Tk look and feel.  Try the Windows/MFC version instead?  I'm not sure
but the wpy implementation may be detecting the tk installation and
preferring it automatically; maybe look at the code...
  -- Aaron Watters
===
...Lawyers don't hunt elephants, but they will claim to own a
whole herd based on the "look and feel" of one dropping...
  -- From "how to hunt an elephant"


Tue, 04 Apr 2000 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Win 3.1 wpy raise ImportError no wpy physical implementation found

2. windows and wpy

3. wpy on NT4.0 , problem

4. New WPY with Python 1.5

5. wpy, win 3.1: More than one script.

6. wpy on MacOS

7. WPy window handles

8. WPY

9. New WPY Version 0.51

10. WPY: import dll for socket

11. wpy problem

12. WPY: tk_messagebox

 

 
Powered by phpBB® Forum Software