Help sought for compiling Python 1.4 on Solaris 2.4 with gcc 2.7.2 
Author Message
 Help sought for compiling Python 1.4 on Solaris 2.4 with gcc 2.7.2

I am trying to figure out how to configure Python.  Perhaps I am
trying too hard.  I look at configure's --help, and I see things
like dynamic libraries, math libraries, etc.  I want to specify these
things so that I can use them. However, I can't seem to specify Sun's
dynamic library.  It doesn't seem to help configure find hypot if
I specify -lm to the part for finding libm, etc.  When I try to build
I still get failures in several parts of python (importld.c can't find
dl.h - which Sun's dl support doesn't have, and then later the code
can't find a rule for building one of the libraries).

When I try to use the Makefile in the Doc directory, I get syntax
errors from one of the .tex files.

Seems like it's a lot tougher to build Python than it is Tcl, Perl, or
most of the other languages I have built over the years.

But perhaps there are some patches I am missing.  Can someone point me
either to a set of flags that I will need to build Python 1.4 on
the above platform, or a set of patchs so that it will work?  I am
anxious to get 1.4 built.
--

:s <URL: http://www.*-*-*.com/ %7Elvirden/> <*> O- "We are all Kosh."
:s Unless explicitly stated to the contrary, nothing in this posting should
:s be construed as representing my employer's opinions.



Thu, 15 Apr 1999 02:00:00 GMT  
 Help sought for compiling Python 1.4 on Solaris 2.4 with gcc 2.7.2

Make sure that you are using sun's linker and not the gnu linker.  It is
broken for dynamic code.  gcc should produced relocatable code under solaris
by default.  To see if it does, compile a simple program and then type
file a.out...  You should see something like 32-bit MSN Elf relocatable
executable.

I use the SUNpro compiler and configure using:

        setenv CC /opt/SUNWspro/bin/cc
        ./configure --without-gcc --with-threads

Make sure to edit the Setup file in the Modules directory.  Good luck.
--

     - Zack


Box 220, Brown University, Providence, RI 02912
Phone: (401) 863 - 5435



Thu, 15 Apr 1999 02:00:00 GMT  
 Help sought for compiling Python 1.4 on Solaris 2.4 with gcc 2.7.2

Quote:
>>> Larry W. Virden wrote

> I am trying to figure out how to configure Python.  Perhaps I am
> trying too hard.  I look at configure's --help, and I see things

Try just using ./configure, then editing Modules/Setup.in to include
-lm on the math and cmath lines.

(is there any reason this isn't the default??)

Anthony



Thu, 15 Apr 1999 02:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Tk4.1 compile on Solaris 2.4 with gcc 2.7.2 failing

2. Compiling Tcl w/ Solaris 2.4 and gcc 2.6.3

3. Compiling Python for Solaris 2.4

4. Compiling TCL on Solaris 2.4 HELP!!

5. Compiling tcl7.4b2 on solaris 2.4 - Need help!

6. building Tcl7.5 on Solaris 2.4 with gcc

7. gcc 2.7.2, sparc-solaris 2.4, and tcl 7.5

8. Expect, tcl, Solaris 2.4/5, gcc 2.6.3

9. sybtcl bug(?) on Solaris 2.4 with gcc

10. Can't compile gforth-0.3.0 on Sparc Solaris 2.4

11. Compiling Fortran on Solaris 2.5 for 2.4

12. Compiling cprolog on Solaris 2.4 ?

 

 
Powered by phpBB® Forum Software