My modules doesn't seem to reload in IIS asp pages 
Author Message
 My modules doesn't seem to reload in IIS asp pages

I am writing .asp pages with Python, and my modules doesn't seem to reload.

I see changes i make in the html when editing the page, but changes I make
in the modules does not go through.

Isn't this correct?


<%
import marcipan
reload(marcipan)
from marcipan.Receipees import Receipees, Categories

# stuff
rcps = Receipees()
id = Request(rcps.getKey())
if str(id) != 'None':
    rcp = rcps.getOneById(id)
else:
    rcp = rcps.getNew()
%>

Win2K, SP2, Python2.11

regards Max M



Sat, 10 Apr 2004 21:54:56 GMT  
 My modules doesn't seem to reload in IIS asp pages
Try to change the code to:


<%

from marcipan.Receipees import Receipees, Categories

reload(Receipees)
reload(Categories)

# stuff
rcps = Receipees()
id = Request(rcps.getKey())
if str(id) != 'None':
    rcp = rcps.getOneById(id)
else:
    rcp = rcps.getNew()

%>

Should work fine that way...

Pieter

Quote:
-----Original Message-----

Sent: Tuesday, October 23, 2001 3:55 PM

Subject: My modules doesn't seem to reload in IIS asp pages

I am writing .asp pages with Python, and my modules doesn't seem to reload.

I see changes i make in the html when editing the page, but changes I make
in the modules does not go through.

Isn't this correct?


<%
import marcipan
reload(marcipan)
from marcipan.Receipees import Receipees, Categories

# stuff
rcps = Receipees()
id = Request(rcps.getKey())
if str(id) != 'None':
    rcp = rcps.getOneById(id)
else:
    rcp = rcps.getNew()
%>

Win2K, SP2, Python2.11

regards Max M

--
http://mail.python.org/mailman/listinfo/python-list



Sat, 10 Apr 2004 22:00:22 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. IIS hangs when using Topspeed ODBC with Active Server Pages (ASP)

2. Solution: using the FieldStorage in .asp pages under IIS

3. More IIS crashing and blank .asp pages

4. IIS and ASP pages

5. IIS and ASP pages

6. Pythonwin IIS-ASP module imports (bug)

7. Accessing ASP-IIS objects in modules

8. Python + IIS/ASP questions (modules, namespaces, etc)

9. expect's full_buffer doesn't seem to work

10. PHP as CGI with IIS on WinXP doesn't work

11. set VIDEO_MODE_RESTRICTION=CGA doesn't seem to work

12. ios.gets doesn't seem to work as advertised

 

 
Powered by phpBB® Forum Software