Problem: readline in Python 2.1 on SuSE 7.1 
Author Message
 Problem: readline in Python 2.1 on SuSE 7.1

Problem installing python 2.1 on SuSE 7.1 with readline support.

I've tried several variations of the configuration options

#readline readline.c -lreadline -ltermcap
#readline readline.c -lreadline
#readline readline.c -L/usr/lib -lreadline
readline readline.c -lreadline -L/usr/share/misc/termcap

None of them worked.  Any ideas?  Following are what I found on the system:

$ locate termcap
/etc/termcap
/usr/include/termcap.h
/usr/lib/perl5/5.6.0/termcap.pl
/usr/lib/perl5/site_perl/5.6.0/i586-linux/termcap.ph
/usr/lib/zsh/3.1.9/zsh/termcap.so
/usr/share/doc/packages/wterm/etc/wterm.termcap
/usr/share/emacs/20.7/etc/termcap.src
/usr/share/man/man3/termcap.3ncurses.gz
/usr/share/man/man5/termcap.5.gz
/usr/share/misc/termcap
/usr/share/zsh/help/termcap
/usr/X11R6/lib/X11/etc/sun.termcap
/usr/X11R6/lib/X11/etc/xterm.termcap

Huaiyu



Mon, 26 Jan 2004 09:33:34 GMT  
 Problem: readline in Python 2.1 on SuSE 7.1

Quote:

> Problem installing Python 2.1 on SuSE 7.1 with readline support.

> I've tried several variations of the configuration options

> #readline readline.c -lreadline -ltermcap
> #readline readline.c -lreadline
> #readline readline.c -L/usr/lib -lreadline
> readline readline.c -lreadline -L/usr/share/misc/termcap

> None of them worked.

Python 2.1 uses distutils to compile in readline. If setup.py
doesn't find readline, you have to patch setup.py, not the
Modules/Setup file.

Quote:
> Any ideas?  Following are what I found on the system:

> $ locate termcap
> /etc/termcap
> /usr/include/termcap.h
> /usr/lib/perl5/5.6.0/termcap.pl
> /usr/lib/perl5/site_perl/5.6.0/i586-linux/termcap.ph
> /usr/lib/zsh/3.1.9/zsh/termcap.so
> /usr/share/doc/packages/wterm/etc/wterm.termcap
> /usr/share/emacs/20.7/etc/termcap.src
> /usr/share/man/man3/termcap.3ncurses.gz
> /usr/share/man/man5/termcap.5.gz
> /usr/share/misc/termcap
> /usr/share/zsh/help/termcap
> /usr/X11R6/lib/X11/etc/sun.termcap
> /usr/X11R6/lib/X11/etc/xterm.termcap

--
Marc-Andre Lemburg
CEO eGenix.com Software GmbH
______________________________________________________________________
Consulting & Company:                           http://www.egenix.com/
Python Software:                        http://www.lemburg.com/python/


Mon, 26 Jan 2004 23:20:47 GMT  
 Problem: readline in Python 2.1 on SuSE 7.1

Quote:

> Problem installing Python 2.1 on SuSE 7.1 with readline support.

> I've tried several variations of the configuration options

> #readline readline.c -lreadline -ltermcap
> #readline readline.c -lreadline
> #readline readline.c -L/usr/lib -lreadline
> readline readline.c -lreadline -L/usr/share/misc/termcap

I ran into the same problem. Here is my solution:

readline readline.c -lreadline -lncurses

I hope that helps.

-v
--
Victor R. Cardona
 10:13am  up 18 days, 12:19,  3 users,  load average: 2.53, 2.34, 2.29
Powered by SuSE Linux 7.1 (i386) 2.4.5-64GB-SMP



Mon, 26 Jan 2004 23:16:19 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Readline on RedHat 7.1 with Python 2.1

2. Redhat 7.1 and Python 2.1

3. Redhat 7.1 and Python 2.1

4. ifc 7.1 on SuSE 8.2 64bits linking problem.

5. can't install vw5i.4 on suse 7.1

6. MF-Cobol with SUSE 7.1

7. segmentation fault on Suse Linux 7.1, not on FreeBSD 3.3

8. readline completion for python 2.1 on win32?

9. readline, python 2.1 and LFS

10. building Python+readline on Suse 6.0

11. Python 2.1 == Jython 2.1 != Python 2.2?

12. Link problem embedding Python, gcc, Python 2.1, Suse7.3

 

 
Powered by phpBB® Forum Software