PHP 4.1.2 on apache 1.3.23, on RedHat 7.3 - weird problem with LoadModule php4_module 
Author Message
 PHP 4.1.2 on apache 1.3.23, on RedHat 7.3 - weird problem with LoadModule php4_module

I am trying to get PHP working on apache 1.3.23 under Red Hat Linux 7.3.

I figured out that the httpd.conf has no php module load command, but
when I add the LoadModule line for php to /etc/httpd/conf/httpd.conf and
restart I get a totally broken web server:

LoadModule php4_module        modules/libphp4.so

No other changes were made, but when I restart httpd, suddenly the web
server runs but no documents will load.   I get something about
authorization failure if I try "lynx http://localhost/".  If I "telnet
localhost 80" then I get a connection and I can do a request but nothing
else works.

I don't know why.  Is this a faq?  I have installed first the binary
RPMs, then rebuilt from the SRPMS and reinstalled. All still the same.

Help!

Warren Postma



Sun, 22 May 2005 03:50:56 GMT  
 PHP 4.1.2 on apache 1.3.23, on RedHat 7.3 - weird problem with LoadModule php4_module

Quote:
> I don't know why.  Is this a faq?  I have installed first the binary
> RPMs, then rebuilt from the SRPMS and reinstalled. All still the same.

Okay, if I delete httpd.conf, and reinstall the rpm, it overwrites my
busted httpd.conf with a working one.  That did it.

Warren



Sun, 22 May 2005 05:22:29 GMT  
 PHP 4.1.2 on apache 1.3.23, on RedHat 7.3 - weird problem with LoadModule php4_module

Quote:

> Okay, if I delete httpd.conf, and reinstall the rpm, it overwrites my
> busted httpd.conf with a working one.  That did it.

this goes to show: always backup configuration files before you modify
them ... better to be safe than sorry.

--
Registered Linux User #273744
<www.volutin.net -- everything irrelevant>



Sun, 22 May 2005 19:39:37 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. PHP 4.2.2 or 4.2.3 on RedHat 7.3

2. Redhat 7.3 PHP RPM + Payflow Pro functions -- HELP

3. Help Porting PHP Sites from Solaris to RedHat 7.3

4. strange behaviour of LIB mkind on redhat 7.3 (sysfileok problem)

5. Solution - Apache, Redhat 8.0, PHP & MySQL

6. Apache, Redhat 8.0, PHP & MySQL

7. oh *drat*, xved falls over on redhat 7.3

8. relinking poplog for redhat 7.3

9. bash via ved:imsh under Redhat 7.3

10. Ruby in Redhat 7.3

11. RedHat 7.3

12. RedHat 7.3 (Kevin Dahlhausen)

 

 
Powered by phpBB® Forum Software