trouble with iis not passing variables 
Author Message
 trouble with iis not passing variables

Hi there,

I have recently built a new computer to do web development on and
currently the set up consists of a PIII running Win XP Pro with IIS and PHP.

Everything seems to be working fine except for the fact the variables
are not being passed from forms to my script. They show up in the
phpinfo() but the form says the variables are undefined!?

This never used to happen when I worked with Apache, but I'd like to try
and get IIS working properly.

For what it's worth, I've uploaded the script to my hosts server and
it's running there with no trouble, so I'm sure this is a problem with
how I've configured IIS.

Anyone offer some advice?

BTW, I'm a newbie with both XP and IIS so there is every reason to
suspect I have just missed something in the setup...

Thanks.



Thu, 23 Jun 2005 13:28:57 GMT  
 trouble with iis not passing variables
On Sun, 05 Jan 2003 16:28:57 +1100, Lucien Stals

Quote:

>Everything seems to be working fine except for the fact the variables
>are not being passed from forms to my script. They show up in the
>phpinfo() but the form says the variables are undefined!?

It sounds like register_globals is disabled.  

http://www.php.net/manual/en/security.registerglobals.php



Thu, 23 Jun 2005 14:22:27 GMT  
 trouble with iis not passing variables
Thanks for that.

Looks like your right. I got it working by explicitly referancing the
variables (eg $HTTP_POST_VARS["var_name_here"])

Quote:

> On Sun, 05 Jan 2003 16:28:57 +1100, Lucien Stals

>>Everything seems to be working fine except for the fact the variables
>>are not being passed from forms to my script. They show up in the
>>phpinfo() but the form says the variables are undefined!?

> It sounds like register_globals is disabled.  

> http://www.php.net/manual/en/security.registerglobals.php



Thu, 23 Jun 2005 14:58:42 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. openMP: threadprivate not effected and function variables not passed

2. php variables not passing through

3. session not passing variable

4. db variables not being passed

5. config xitami/php: variables not passed

6. GET variable not being passed?

7. Variable not passing in HTML form to PHP sendmail script

8. Variable Not Passed With $_SERVER['PHP_SELF']

9. Trouble with cgi.FieldStorage() on iis/asp

10. Trouble with IIS Python ASP

11. Character variable variable passed as a subroutine argument

12. Pass variable to variable by reference?

 

 
Powered by phpBB® Forum Software