dlname error trying to make install php4 
Author Message
 dlname error trying to make install php4

I'm having a problem with make install and php4.

OS: Cygwin on XP (but I dont think the problem is with cygwin)

apache2.0.43 compile/install:
        ./configure --enable-so
        make
        make install

httpd server sucessfully tested: starts from /usr/local/apache2/bin

php-4.3.0 compile/install:
        ./configure --with-apxs2=/usr/local/apache2/bin/apxs
        make
        make install
        cp php.ini-dist /usr/local/lib/php.ini

Initially I got the error:
        $ make install
        Installing PHP CLI binary:      /usr/local/bin/
        Installing PHP SAPI module
        /usr/local/apache2/build/instdso.sh
SH_LIBTOOL='/usr/local/apache2/build/libtool
        ' libphp4.la /usr/local/apache2/modules
        /usr/local/apache2/build/libtool --mode=install cp libphp4.la
/usr/local/apache2/modules/
        cp .libs/libphp4.lai /usr/local/apache2/modules/libphp4.la
        cp .libs/libphp4.a /usr/local/apache2/modules/libphp4.a
        ranlib /usr/local/apache2/modules/libphp4.a
        chmod 644 /usr/local/apache2/modules/libphp4.a
        libtool: install: warning: remember to run `libtool --finish    
/home/Polakos/Download/php-4.3.0/libs'
        Warning!  dlname not found in
/usr/local/apache2/modules/libphp4.la.
        Assuming installing a .so rather than a libtool archive.
        chmod 755 /usr/local/apache2/modules/libphp4.so
        chmod: getting attributes of
`/usr/local/apache2/modules/libphp4.so': No such file or directory
        apxs:Error: Command failed with rc=65536
        .
        make: *** [install-sapi] Error 1

After reading another help message someone tried to rename:
\usr\local\apache2\modules\libphp4.a
to
\usr\local\apache2\modules\libphp4.so

after doing this make install worked, but when trying to start httpd I
get ths error:
Syntax error on line 232 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into server: dlopen:
Win32 error 126

I've been struggling for days at this so any help would be
appriciated.  I am not even sure why you need to rename that file (why
isnt it already there)
Also why do I get this message durring the make:
Warning!  dlname not found in  /usr/local/apache2/modules/libphp4.la.
that file does exist!



Sun, 26 Jun 2005 01:13:32 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. new install, Error when trying to run examples

2. PHP4 - trying to run windows commands

3. error trying to install DCOracle2 in zope

4. Problem Installing PHP4.3 on Debian Linux

5. Newbie cannot install PHP4.3.0 on Apache 2

6. Install problems with PHP4 on windows XP

7. php4.2.3/apache1.3.27/apxs configure error

8. try gfdg try kuiou try gsdfas try

9. Error (513): Internal error 13 (try to browse a pervasive file from dct in C5)

10. Error VEEXT700: Linker Failed Error 511 when trying to compile project for DM 2.6

11. Trying to install EON on DOS

12. MSI problem when trying to install LabView 6i

 

 
Powered by phpBB® Forum Software