MetaBase connection problems 
Author Message
 MetaBase connection problems

I am having problems with getting MetaBase to connect to my server, and
was wondering if anyone else has come across this. Basically, I have a
directory that contains a file called 'metabase.php' and directory
called 'metabase' that contains all the files for the package (even
upgraded to the metabase-dev files). The contents of metabase.php are below:
<?php
     require dirname(__FILE__).'/metabase/metabase_interface.php';
     require dirname(__FILE__).'/metabase/metabase_database.php';

     $dsn=array(
         "Type"=>"mysql",
         "User"=>"phpuser",
         "Password"=>"php"
     );

     $error=MetabaseSetupDatabaseObject($dsn,$db);
     if($error!=""){
             echo $error;
             exit;
     }
     $db->SetDatabase("test");
     echo "success";
?>

When I browse to the metabase.php page, I get the error string saying:
it was not specified an existing DBMS driver file

Obviously, the class is being defined since that is the only error I get
(E_ALL) and it is a Metabase error.

Any suggestions?

--

PHP POSTERS: Please use comp.lang.php for PHP related questions,
              alt.php* groups are not recommended.



Mon, 30 May 2005 03:31:55 GMT  
 MetaBase connection problems

Quote:
> I am having problems with getting MetaBase to connect to my server, and
> was wondering if anyone else has come across this. Basically, I have a
> directory that contains a file called 'metabase.php' and directory
> called 'metabase' that contains all the files for the package (even
> upgraded to the metabase-dev files). The contents of metabase.php are
> below:
> <?php
>     require dirname(__FILE__).'/metabase/metabase_interface.php';
>     require dirname(__FILE__).'/metabase/metabase_database.php';

>     $dsn=array(
>         "Type"=>"mysql",

Add here:

          "IncludePath"=>dirname(__FILE__).'/metabase',

Quote:
>         "User"=>"phpuser",
>         "Password"=>"php"
>     );

>     $error=MetabaseSetupDatabaseObject($dsn,$db);
>     if($error!=""){
>             echo $error;
>             exit;
>     }
>     $db->SetDatabase("test");
>     echo "success";
> ?>

> When I browse to the metabase.php page, I get the error string saying:
> it was not specified an existing DBMS driver file

> Obviously, the class is being defined since that is the only error I get
> (E_ALL) and it is a Metabase error.

> Any suggestions?

Yes the class was not considering the include path set in php.ini. There
is a new version that supports it now here:

http://groups.yahoo.com/group/metabase-dev/files/beta/

--

Regards,
Manuel Lemos



Mon, 30 May 2005 15:19:02 GMT  
 MetaBase connection problems

Quote:


>> I am having problems with getting MetaBase to connect to my server,
>> and was wondering if anyone else has come across this. Basically, I
>> have a directory that contains a file called 'metabase.php' and
>> directory called 'metabase' that contains all the files for the
>> package (even upgraded to the metabase-dev files). The contents of
>> metabase.php are below:
>> <?php
>>     require dirname(__FILE__).'/metabase/metabase_interface.php';
>>     require dirname(__FILE__).'/metabase/metabase_database.php';

>>     $dsn=array(
>>         "Type"=>"mysql",

> Add here:

>       "IncludePath"=>dirname(__FILE__).'/metabase',

>>         "User"=>"phpuser",
>>         "Password"=>"php"
>>     );

Thanks! That was exactly what my problem was. I added the IncludePath to
my $dsn array, and all works great.

--

PHP POSTERS: Please use comp.lang.php for PHP related questions,
              alt.php* groups are not recommended.



Mon, 30 May 2005 22:06:37 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Metabase 5.0 interface wanted.

2. FTPOpen Data Connection: Could not establish connection

3. TCP/IP AbtSocket connection problems

4. Problem with Topspeed ODBC connection

5. Clarion ASP ADO-Connection Problem

6. Database connection problem

7. ODBC Sybase Connection Problem

8. Oracle connection problem VW2

9. asp topspeed connection problem

10. Problems with TAYGETA connection?!

11. Problem of connection DB2 with Object REXX

12. Object Rexx problems with cgi's when using IBM internet connection server

 

 
Powered by phpBB® Forum Software