script won't run...displays script text 
Author Message
 script won't run...displays script text

how do i make my perl script run?

UNIX system...
I've uploaded the script file via ftp...
I've used chmod 755 on the file name and checked that using the command
ls -l...

I know the 'action' in the HTML page is correct (directory-wise) because

the script does display as text.

I'm using cgi-lib.pl with require "cgi-lib.pl"; in the script...

any response greatly appreciated,

Kelly Monsrud



Fri, 04 Aug 2000 03:00:00 GMT  
 script won't run...displays script text

Quote:

> how do i make my perl script run?

> UNIX system...
> I've uploaded the script file via ftp...
> I've used chmod 755 on the file name and checked that using the command
> ls -l...

> I know the 'action' in the HTML page is correct (directory-wise) because

> the script does display as text.

Sounds like the directory you are running the script from isn't
configured in your server. Talk to your sysadmin.

This question does not belong in the perl newsgroup, try

HTH
Bob Trieger



Fri, 04 Aug 2000 03:00:00 GMT  
 script won't run...displays script text

 [courtesy cc of this posting sent to cited author via email]


:how do i make my perl script run?

Get up at 91 minutes before dawn, clothe yourself in neon green body
paint and nothing else, pour a little (blended) scotch out on the ground,
face the east, and cluck like a hen.

:I know the 'action' in the HTML page is correct (directory-wise) because

You have a web config problem.  This is unrelated to Perl, and anathema
to this newsgroup.

:I'm using cgi-lib.pl with require "cgi-lib.pl"; in the script...

Well, that was your third mistake.  Wouldn't you just rip out
your fingernails -- slowly -- instead of using that old thing?

Here, read these:

    The CGI Newsgroup (NOT THIS ONE):
        comp.infosystems.www.authoring.cgi

    CPAN's Web-related modules in Perl:
        http://www.perl.com/CPAN/modules/by-category/15_World_Wide_Web_HTML_H...

    The Idiot's Guide to solving Perl/CGI problems
        http://www.perl.com/perl/faq/idiots-guide.html

    Perl FAQs
        http://www.perl.com/CPAN/doc/FAQs/

    Perl Manpages (old)
        http://www.perl.com/CPAN/doc/manual/html/

    CGI FAQ
        http://www.webthing.com/page.cgi/cgifaq

    WWW Security FAQ
        www-genome.wi.mit.edu/WWW/faqs/www-security-faq.html

    Web FAQ
        http://www.boutell.com/faq/

    HTTP Spec
        http://www.w3.org/pub/WWW/Protocols/HTTP/

    HTML Spec
        http://www.w3.org/pub/WWW/MarkUp/

    CGI Spec
        http://hoohoo.ncsa.uiuc.edu/cgi/interface.html

--tom
--

    X-Windows: It could be worse, but it'll take time.
        --Jamie Zawinski



Sat, 05 Aug 2000 03:00:00 GMT  
 script won't run...displays script text

  [courtesy cc of this posting sent to cited author via email]


: how do i make my perl script run?

Hmm.  Sounds like something that may be addressed in the docs.  But I'm game.

: UNIX system...
: I've uploaded the script file via ftp...
: I've used chmod 755 on the file name and checked that using the command
: ls -l...

So far, so good.  You've got my attention.

: I know the 'action' in the HTML page is correct (directory-wise) because

D'oh!  It's a CGI/httpd configuration question.  You were *so* close to being
on-topic.  You'll want to ask the same exact question over in


assuming, of course, that you've first read both the documentation for your
httpd and that newsgroup's FAQ.  You might want to browse ours, too.  It would
have told you what I'm telling you now, and without being so irritatingly
facetious.

--
#!/usr/bin/perl -w -- Just another Perl hacker,

 y \,y,<STDIN>,,eval"sub $_ {print'$}'}"),y,} \,},>STDOUT,,&$_}



Sat, 05 Aug 2000 03:00:00 GMT  
 script won't run...displays script text



Quote:
> how do i make my perl script run?

http://www.perl.com/CPAN/doc/FAQs/cgi/idiots-guide.html
http://www.perl.com/CPAN/doc/FAQs/cgi/perl-cgi-faq.html

and configure your web server to recognise the thing as a CGI. Or
place it in a directory that is configured to contain CGI scripts.
Contact your ISP to find out if you're allowed to run CGI at all, and
if so, how. etc.. etc..

In other words: This has NOTHING to do with perl.

Quote:
> I'm using cgi-lib.pl with require "cgi-lib.pl"; in the script...

bad, bad, bad. You should use CGI.pm.

Martien
--
Martien Verbruggen                  |
Webmaster www.tradingpost.com.au    | If it isn't broken, it doesn't have
Commercial Dynamics Pty. Ltd.       | enough features yet.
NSW, Australia                      |



Sat, 05 Aug 2000 03:00:00 GMT  
 script won't run...displays script text



: :how do i make my perl script run?
:
: Get up at 91 minutes before dawn, clothe yourself in neon green body
: paint and nothing else, pour a little (blended) scotch out on the ground,
                                         ^^^^^^^
With all due respect, you've misspelled "single-malt."

--



Sat, 05 Aug 2000 03:00:00 GMT  
 script won't run...displays script text

Quote:



>: :how do i make my perl script run?
>:
>: Get up at 91 minutes before dawn, clothe yourself in neon green body
>: paint and nothing else, pour a little (blended) scotch out on the ground,
>                                         ^^^^^^^
>With all due respect, you've misspelled "single-malt."

With all due respect, one does not pour a single-malt[0] out on the ground.

[0] Except possibly the handful of single-malts the mega-distilleries really
        should just keep for their blends, rather than release.

--
Michael W Peterson                      <http://www.flash.net/~michael/>
Chief System Administrator              FlashNet Communications
Unix: more than enough rope...



Sat, 05 Aug 2000 03:00:00 GMT  
 script won't run...displays script text

 [courtesy cc of this posting sent to cited author via email]


:: paint and nothing else, pour a little (blended) scotch out on the ground,
:                                         ^^^^^^^
:With all due respect, you've misspelled "single-malt."

I think not.  I know what to throw away and what to keep. :-)

--tom
--

    "111% of {*filter*}is everything." --Larry Wall



Sat, 05 Aug 2000 03:00:00 GMT  
 script won't run...displays script text




+ : :how do i make my perl script run?

+ : Get up at 91 minutes before dawn, clothe yourself in neon green body

Ummm...Tom? is this is "kinder, gentler" you?? ;)

+ : paint and nothing else, pour a little (blended) scotch out on the ground,
+                                          ^^^^^^^
+ With all due respect, you've misspelled "single-malt."

With all due respect, if I find out you've been pouring single-malt
scotch out on the ground, I'm gonna thump you into next week.

James - I'm buying up stocks of neon green body paint...

--
Consulting Minister for Consultants, DNRC
The Bill of Rights is paid in Responsibilities - Jean McGuire
To cure your perl CGI problems, please look at:
<url:http://www.perl.com/CPAN-local/doc/FAQs/cgi/idiots-guide.html>



Sat, 05 Aug 2000 03:00:00 GMT  
 
 [ 9 post ] 

 Relevant Pages 

1. Please Help:My script runs on win32, it won't run on Unix

2. My script runs on win32, it won't run on Unix

3. Please Help: My script runs on win32, it won't run on Unix

4. perl 4 script that won't run under perl 5

5. why won't this short script run?

6. Perl CGI scripts won't run without -w switch (under Apache 1.3.x)

7. Perl scripts won't run on Linux

8. IIS4.0 won't run perl scripts which call external commands

9. system() won't run shell script correctly

10. perl script won't run correctly inside emacs

11. Server won't run Perl scripts (Fasttrack)

12. Server won't run Perl scripts

 

 
Powered by phpBB® Forum Software