segmentation faults on AIX 
Author Message
 segmentation faults on AIX

Hi. I'm trying to figure out just what is causing the
following. First, some good output ...

$ /usr/local/bin/perl -v

This is perl, version 5.005_02 built for aix

Copyright 1987-1998, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5.0 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using `man perl' or `perldoc perl'.  If you have access to the
Internet, point your browser at http://www.*-*-*.com/ , the Perl Home Page.

$

Now here's the puzzle ...

$ /usr/local/bin/perl -V
Segmentation fault(coredump)
$

... and yet ...

$ cd /usr/local/bin
$ ./perl -V
Summary of my perl5 (5.0 patchlevel 5 subversion 2) configuration:
  Platform:
    osname=aix, osvers=4.2.1.0, archname=aix
    uname='aix plum 2 4 000008527500 '
    hint=previous, useposix=true, d_sigaction=define
    usethreads=undef useperlio=undef d_sfio=undef
  Compiler:
    cc='cc', optimize='-O -qmaxmem=32768', gccversion=
    cppflags='-D_ALL_SOURCE -D_ANSI_C_SOURCE -D_POSIX_SOURCE -I/usr/local/include'
    ccflags ='-D_ALL_SOURCE -D_ANSI_C_SOURCE -D_POSIX_SOURCE -I/usr/local/include'
    stdchar='unsigned char', d_stdstdio=define, usevfork=false
    intsize=4, longsize=4, ptrsize=4, doublesize=8
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=8
    alignbytes=8, usemymalloc=n, prototype=define
  Linker and Libraries:
    ld='ld', ldflags =' -L/usr/local/lib'
    libpth=/usr/local/lib /lib /usr/lib /usr/ccs/lib
    libs=-lnsl -ldbm -ldl -lld -lm -lc -lbsd -lPW
    libc=/lib/libc.a, so=a, useshrplib=false, libperl=libperl.a
  Dynamic Linking:
    dlsrc=dl_aix.xs, dlext=so, d_dlsymun=undef, ccdlflags='-bE:perl.exp'
    cccdlflags=' ', lddlflags='-bhalt:4 -bM:SRE -bI:$(PERL_INC)/perl.exp -bE:$(BASEEXT).exp -b noentry -lc -L/usr/local/lib'

Characteristics of this binary (from libperl):
  Built under aix
  Compiled at Oct 28 1998 13:49:33

    /usr/local/lib/perl5/5.00502/aix
    /usr/local/lib/perl5/5.00502
    /usr/local/lib/perl5/site_perl/5.005/aix
    /usr/local/lib/perl5/site_perl/5.005
$

The version of perl is old, but I can't upgrade it. Also, it was built
on a machine running AIX 4.2.1, but running under AIX 4.3.3.

I'm hoping someone else running Perl under AIX has seen something like
this - perhaps this is a shell bug, and not a perl problem? I'm using
the Korn Shell as my shell, but the same behavior happens under the C
shell (just tried it). My searching on Google didn't turn up anything
that seemed to help either, so it's to the newsgroups I go.

Any AIX/Perl experts out there with suggestions? Thanks in advance.

--
### Art Haas - (713) 689-2417
# They that can give up essential liberty to obtain a little temporary
# safety deserve neither liberty nor safety.
# -- Benjamin Franklin, Historical Review of Pennsylvania, 1759



Mon, 17 May 2004 21:26:44 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Segmentation fault w/ perl-5.001 on AIX-3.2.5

2. PL_perl_destruct_level = 1 -> segmentation fault

3. Tkperl 5.000 Segmentation Fault

4. Segmentation Fault on Pattern Match?!?!

5. Segmentation fault in perl5.000

6. debugging Segmentation fault

7. tkperl segmentation fault...

8. perl-5.000 segmentation fault - sort subroutine

9. Perl 5.8.0 Segmentation fault(critical)

10. tkperl segmentation fault

11. Segmentation fault in perl 5.8.0

12. Segmentation fault using debugger in perl5b1.

 

 
Powered by phpBB® Forum Software