After installing new Activestate version .. @INC errors 
Author Message
 After installing new Activestate version .. @INC errors

I installed the TK module using ppm.bat and it is in
C:\perl\site\5.005\lib\MSWin32-x86-object\auto\Tk\

I now have installed v5.00502

when I try to use TK
I get the error

C:\perl\site\5.00502\lib\MSWin32-x86-object ....)
                  ^^


any help with this would be appreciated

TIA,
Kent



Sat, 03 Feb 2001 03:00:00 GMT  
 After installing new Activestate version .. @INC errors

Your code should read (note the capitalization):

   use Tk;

--

http://pobox.com/~jdf/



Sat, 03 Feb 2001 03:00:00 GMT  
 After installing new Activestate version .. @INC errors
my message was sloppy .. in the code the capitalization is correct ..
use TK;
the problem seems to be that the TK modules are in the 5.005 tree

Quote:

> I installed the TK module using ppm.bat and it is in
> C:\perl\site\5.005\lib\MSWin32-x86-object\auto\Tk\

> I now have installed v5.00502

> when I try to use TK
> I get the error

> C:\perl\site\5.00502\lib\MSWin32-x86-object ....)
>                   ^^


> any help with this would be appreciated

> TIA,
> Kent



Sat, 03 Feb 2001 03:00:00 GMT  
 After installing new Activestate version .. @INC errors
) I installed the TK module using ppm.bat and it is in
) C:\perl\site\5.005\lib\MSWin32-x86-object\auto\Tk\
)
) I now have installed v5.00502
)
) when I try to use TK
) I get the error

) C:\perl\site\5.00502\lib\MSWin32-x86-object ....)
)                   ^^
)

) any help with this would be appreciated

You have to read the C code [which I haven't done for this case].
It is computed dynamically.  This is a fairly new feature (as is

("MSWin32-x86-object") were added to the paths.

For now I'd only install Perl into directories using full-length
version numbers.  So I'd uninstall and reinstall ActivePerl and
be sure to report this to ActiveState [they, not the regular perl
porters, provide PPM].

The full version number in the path is good for web publishers
who want their old webs to continue to use 5.004_01 while they
test out new webs on 5.004_02.  For the rest of us, they are
a pain.

In any case, trying to allow "site" to be either "5.xxx/site"
or "site/5.xxx" may have been a mistake.  I'd rather have
the version number only one place [and doing that would have
prevented your problem].
--
Tye McQueen    Nothing is obvious unless you are overlooking something
         http://www.metronet.com/~tye/ (scripts, links, nothing fancy)



Sun, 04 Feb 2001 03:00:00 GMT  
 After installing new Activestate version .. @INC errors

Quote:


> ) I installed the TK module using ppm.bat and it is in
> ) C:\perl\site\5.005\lib\MSWin32-x86-object\auto\Tk\
> )
> ) I now have installed v5.00502
> )
> ) when I try to use TK
> ) I get the error

> ) C:\perl\site\5.00502\lib\MSWin32-x86-object ....)

I came to the newsgroups today for this exact same reason.  To add
another
symptom to the problem, I'm used to having some utilities reside in the
/bin
directory, and I can run them from any DOS prompt when I need them.

I installed Perl from the Active State Win32 Perl Resource Kit,
installed
several modules, and then downloaded and installed Build502.  When you
do
that, you get both a C:\Perl\5.005\bin and a C:\Perl\5.00502\bin
directory,
but only the latter is in your path.  

I haven't determined how much of a pain that's going to be, but will be
testing it as I go along, nor whether this is a feature or a bug.  The
docs
don't seem to contain any information on the subject.

David DelGreco

  vcard.vcf
< 1K Download


Tue, 06 Feb 2001 03:00:00 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. New ActiveState "Merge" version 5.00469

2. Installing new modules - how to update @INC

3. How do I install a new module in an ActiveState installation

4. new to Perl- Activestate's PDK wont install

5. New Error Message - @INC

6. ActiveState perl install error Win98

7. Help error in install ActiveState Tk package

8. Error installing packages using ActiveState ppm

9. ActiveState Perl install error on Win/NT 4.0 sp3

10. ActiveState VPN Libnet install error

11. error installing Activestate XML::Parser

12. Install error - activestate perl 5.005

 

 
Powered by phpBB® Forum Software