CGI module not deleting tmp files 
Author Message
 CGI module not deleting tmp files

I'm using the CGI module to upload files to my web server.  However, i
can't seam to get the temp files that it creates to go away.  The
perldoc says those are automatically deleted when the script terminates
but i don't see it happening.  Am i missing an option or something?  Or
is it maybe a bug on windows..?

I know you can get a reference to the file ($ref = $query->upload
('foo')) however that doesn't work for unlinking, obviously, as you
need a string to the file, and the string it returns is the path on the
clients machine.

So my question is, is there any way to get the CGI module to delete
those files with an option.  OR alternatively, is there any way to use
that reference to delete the files?  Thanks for your help in advance!

-jason JAPH

Sent via Deja.com
http://www.*-*-*.com/



Tue, 10 Jun 2003 05:52:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. CGI.pm TEMP files not deleted on NT after file upload

2. Perl -e is not removing files in /tmp directory

3. change tmp dir for file upload in cgi

4. File Upload Temp file not deleted

5. edit a file without /tmp file

6. Perl script to delete files works but not in Crontab

7. unlink ( deleting file) not working

8. Net::FTP does not delete files on NT?

9. unlink ( deleting file) not working

10. Persistence::Object::Simple writing many files to /tmp

11. Writing and reading from /tmp files -PIPES ?

12. Persistence::Object::Simple writing many files to /tmp

 

 
Powered by phpBB® Forum Software