Upgrade 5.004 -> 5.6 and binary modules 
Author Message
 Upgrade 5.004 -> 5.6 and binary modules

Hi,

I am currently running 5.004 and I want to upgrade. I have quite a number
of binary modules installed (some written by me). Does this work? I remember
that I have seen a question 'backward compatibility for binary modules' in
older version of perl. Is this still so?
Are there other caveats in the upgrade?

Konstantin
--

Otkerstr. 28, 81547 Muenchen, Germany. Tel +49 89 69370185
----------------------------------------------------------------------------
"Captain, this ship will not sustain the forming of the cosmos." B'Elana Torres



Wed, 18 Jun 1902 08:00:00 GMT  
 Upgrade 5.004 -> 5.6 and binary modules

Quote:

> Hi,
> I am currently running 5.004 and I want to upgrade. I have quite a number
> of binary modules installed (some written by me). Does this work? I remember
> that I have seen a question 'backward compatibility for binary modules' in
> older version of perl. Is this still so?

Perl 5.6.0 can be built with support for 5.005 modules. Binary
compatibility was broken between perl 5.004 and 5.005. Too much changed
under the hood to maintain it.

                                        Dan



Wed, 18 Jun 1902 08:00:00 GMT  
 Upgrade 5.004 -> 5.6 and binary modules

Quote:

>> Hi,
>> I am currently running 5.004 and I want to upgrade. I have quite a number
>> of binary modules installed (some written by me). Does this work? I remember
>> that I have seen a question 'backward compatibility for binary modules' in
>> older version of perl. Is this still so?
>Perl 5.6.0 can be built with support for 5.005 modules. Binary
>compatibility was broken between perl 5.004 and 5.005. Too much changed
>under the hood to maintain it.

So in that case I can say no to binary compatibility and build it all again
anyway. Thanks for saving my some work \:)

Konstantin

Quote:
>                                    Dan

--

Otkerstr. 28, 81547 Muenchen, Germany. Tel +49 89 69370185
----------------------------------------------------------------------------
"Captain, this ship will not sustain the forming of the cosmos." B'Elana Torres


Wed, 18 Jun 1902 08:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. 5.6 Upgrade - modules

2. Issue with 5.004 to 5.6 upgrade - Use strict now automatic?

3. Upgrading from 5.004 to 5.005

4. Perl 5.004 upgrade problem

5. Upgrading to Perl 5.6 under Debian 2.2

6. Lost Access to Tied Hashes after Perl 5.6 Upgrade

7. Using CPAN.pm without upgrading to Perl 5.6

8. Upgrading to Perl 5.6 under Debian 2.2

9. Can't open DBM after upgrading from 5.005 to 5.6

10. Lost libraries when upgrading from 5.005 to 5.6

11. Upgrading 5.6 to use 64 bit

12. Building binary for Perl 5.004

 

 
Powered by phpBB® Forum Software