Activestate Perl 5.6 crashes 
Author Message
 Activestate Perl 5.6 crashes

I've downloaded the newest and greatest ActiveState Perl 5.6 for Win32.
I also got the PPM update, and the newer XML::Parser module.

What I do is install Perl 5.6. Then I apply the PPM patch. I test it:
everything works. Perl looks to behave pretty normally.

Finally, I decompress the new XML::Parser package ZIP (2.28), as per the
docs (the installer uses XML::Parser so that won't do), and update that
PPM.XML file, as per the docs. Remember, this is on a new and pretty
clean install.

Now, whenever I try to do ANYTHING with XML::Parser, I get an "Illegal
opcode" error in Windows. For example, starting up PPM.BAT: kaboom.
Doing
        perl -MXML::Parser -e "print $XML::Parser::VERSION"

same thing. Kaboom.

Now, I saved the old XML tree (2.27). I use that to overwrite the 2.28
tree again, but to no avail. Perl + XML::Parser keeps crashing. Er... I
must have forgotten to save and restore something.

I can't believe nobody else is having this problem?

BTW this is on Win98.

p.s. Why do WE, the users, have to download the package, and the fix,
and the parser update, and apply the patch, while the whole thing is at
most a few weeks old?

--
        Bart.



Wed, 18 Jun 1902 08:00:00 GMT  
 Activestate Perl 5.6 crashes
Quote:

> I've downloaded the newest and greatest ActiveState Perl 5.6 for Win32.
> I also got the PPM update, and the newer XML::Parser module.

> What I do is install Perl 5.6. Then I apply the PPM patch. I test it:
> everything works. Perl looks to behave pretty normally.

> Finally, I decompress the new XML::Parser package ZIP (2.28), as per the

I think you will find that the ZIP file for XML::Parser is for Perl
version 5.005_03, and is not advertised or intended to work with Perl
5.6 .  XML::Parser version 2.27 seems to work well with Perl 5.6, but
apparently the newer version for 2.28 isn't ready yet.  If you wanted,
maybe you could get the source from CPAN and compile it for 5.6, making
whatever patches are required.
Quote:
> docs (the installer uses XML::Parser so that won't do), and update that
> PPM.XML file, as per the docs. Remember, this is on a new and pretty
> clean install.

> Now, whenever I try to do ANYTHING with XML::Parser, I get an "Illegal
> opcode" error in Windows. For example, starting up PPM.BAT: kaboom.
> Doing
>         perl -MXML::Parser -e "print $XML::Parser::VERSION"

> same thing. Kaboom.

> Now, I saved the old XML tree (2.27). I use that to overwrite the 2.28
> tree again, but to no avail. Perl + XML::Parser keeps crashing. Er... I
> must have forgotten to save and restore something.

> I can't believe nobody else is having this problem?

> BTW this is on Win98.

> p.s. Why do WE, the users, have to download the package, and the fix,
> and the parser update, and apply the patch, while the whole thing is at
> most a few weeks old?

You don't have to.  You can choose not to download, etc.
Quote:

> --
>         Bart.

--
Bob Walton


Wed, 18 Jun 1902 08:00:00 GMT  
 Activestate Perl 5.6 crashes

Quote:

>> Finally, I decompress the new XML::Parser package ZIP (2.28), as per the
>I think you will find that the ZIP file for XML::Parser is for Perl
>version 5.005_03, and is not advertised or intended to work with Perl
>5.6 .  XML::Parser version 2.27 seems to work well with Perl 5.6, but
>apparently the newer version for 2.28 isn't ready yet.

The problem is that it is NOT advertised. Nada. See this page:

        <http://www.activestate.com/ppm/>

Do you see it ANYWHERE that XML::Parser won't work on 5.6.0?

Now, see

        <http://www.activestate.com/ActivePerl/download.htm>

Do you see ANY link offer a download for 5.005_03? I don't.

So 5.6.0 is the only ActivePerl that you can download, and XML::Parser
2.28 is the new XML module. Since there isn't a mention of any
incompatibilities at all, I assumed that those were ment to work
together. I believe that is a fair assumption.

Quote:
>> p.s. Why do WE, the users, have to download the package, and the fix,
>> and the parser update, and apply the patch, while the whole thing is at
>> most a few weeks old?

>You don't have to.  You can choose not to download, etc.

What do you mean? I'm saying it's impossible to download an up to date
package.

Oh  BTW, I can't find ANY link on the entire site to the module section.
Yet it exists at <http://www.activestate.com/PPMpackages/>. Is this a
backdoor or something? Are people not "in the know" not supposed to find
it?

p.s. I found another hidden section:
<http://www.activestate.com/download/> where you CAN find (all?) older
versions. Yet, I had to crawl in through the window to find it.

--
        Bart.



Wed, 18 Jun 1902 08:00:00 GMT  
 Activestate Perl 5.6 crashes
 Bart> Now, see

 Bart>       <http://www.activestate.com/ActivePerl/download.htm>

 Bart> Do you see ANY link offer a download for 5.005_03? I don't.

 Bart> So 5.6.0 is the only ActivePerl that you can download, and XML::Parser
 Bart> 2.28 is the new XML module. Since there isn't a mention of any
 Bart> incompatibilities at all, I assumed that those were ment to work
 Bart> together. I believe that is a fair assumption.

FYI...there's a link to the old build 522 in there somewhere...that's what
I've got installed on my win2k system and it's based on 5.005_03.  I
grabbed it after discovering that PerlScript from the latest build doesn't
work on win2k.
--
Scott Blachowicz



Wed, 18 Jun 1902 08:00:00 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. Perl 5.6 Activestate crashes in Windows 98

2. ActiveState Perl 5.6. and Language Localization

3. ActiveState Perl 5.6 - Can't exit WHILE loop

4. Install MailTools on ActiveState perl 5.6 !!!

5. NEWBIE: Using Win32::Eventlog under Activestate Perl 5.6 (Win XP)

6. NEWBIE: Using Win32::Eventlog under Activestate Perl 5.6 (Win XP)

7. Mail::Sender bad file descriptor (Apache for Win32 on win2k, ActiveState Perl 5.6, Win2k SMTP server)

8. Net::Daemon on activestate perl 5.6

9. ptkdb and ActiveState Perl 5.6 Win32

10. ActiveState Perl 5.6 and Roth pm's

11. mod_perl with activestate perl 5.6 on win32?

12. Install MailTools on ActiveState perl 5.6 !!!

 

 
Powered by phpBB® Forum Software