Compile Perl5.4 on AIX 4.2 with Gcc 2.8.0 
Author Message
 Compile Perl5.4 on AIX 4.2 with Gcc 2.8.0

Hi All...

Has anyone successfully compiled perl 5.4.4 on AIX 4.2 using the gcc 2.8.0
compiler?

I can get it to compile, but it then fails about 17% of the tests.

On the surface, it appears that it is {*filter*} when it hits an "__END__"
tag -- but not in every case (FileHandle.pm works if the __END__ tag is
pulled out).

I appreciate any suggestions on where I should go from here (any special
config things you set, etc., etc. to make it work).  Maybe a "perl -V" if
possible on a successful compile?

Thanks

Alan



Mon, 13 Nov 2000 03:00:00 GMT  
 Compile Perl5.4 on AIX 4.2 with Gcc 2.8.0

If you are refering perl v5.00404, yes. I compiled it using gcc2.8.0 on aix
v4.2.1.0
I could email you the perl -V result if that is what you want

zhang

Quote:

> Hi All...

> Has anyone successfully compiled perl 5.4.4 on AIX 4.2 using the gcc 2.8.0
> compiler?

> I can get it to compile, but it then fails about 17% of the tests.

> On the surface, it appears that it is {*filter*} when it hits an "__END__"
> tag -- but not in every case (FileHandle.pm works if the __END__ tag is
> pulled out).

> I appreciate any suggestions on where I should go from here (any special
> config things you set, etc., etc. to make it work).  Maybe a "perl -V" if
> possible on a successful compile?

> Thanks

> Alan



Tue, 14 Nov 2000 03:00:00 GMT  
 Compile Perl5.4 on AIX 4.2 with Gcc 2.8.0

I have almost the same problem. But it doesn't depend on gcc. It's the
same for cc.

The problem is the right configuration. Some variables in the
config.sh file are not defined which ought to be defined,
e.g. d_umask. And lots of libraries don't have the attended
names on AIX, it seems to me (e.g. -lnet --> -lxnet ??)

The undefined variables then lead to messages like
"The umask funcion is unimplemented"
or
"/lib/socket...skipping test on this platform"

I could make some progress by  naming all system libraries as
additional libraries during the configuration procedure
"-lcurses -lxnet -lxti ...."
but up to now I havn't been able to find a combination of
defined variables and libraries which works and passes
100% of the test. I am above 90%, however.

Perhaps anyone has solved these problems on AIX already?
I am new to this operation system...

Sincerely
Martin

Quote:

> Hi All...

> Has anyone successfully compiled perl 5.4.4 on AIX 4.2 using the gcc 2.8.0
> compiler?

> I can get it to compile, but it then fails about 17% of the tests.

> On the surface, it appears that it is {*filter*} when it hits an "__END__"
> tag -- but not in every case (FileHandle.pm works if the __END__ tag is
> pulled out).

> I appreciate any suggestions on where I should go from here (any special
> config things you set, etc., etc. to make it work).  Maybe a "perl -V" if
> possible on a successful compile?

> Thanks

> Alan

--
===================================================================

Springer-Verlag              __o     phone: +49 (6221) 487 184
Tiergartenstrasse 17       _-\<,_    fax:   +49 (6221) 487 304
D-69121 Heidelberg    ....(_)/ (_)   home phone: +49 (6221) 862384
==== Germany ======================================================


Mon, 20 Nov 2000 03:00:00 GMT  
 Compile Perl5.4 on AIX 4.2 with Gcc 2.8.0

I got it running perfectly with AIX's cc, could send you my "perl -V"
if you like.

Quote:

> If you are refering perl v5.00404, yes. I compiled it using gcc2.8.0 on aix
> v4.2.1.0
> I could email you the perl -V result if that is what you want

Yes, please!
Got the same problems you described with gcc 2.8.1, so I'm very
interested in your gcc version of `perl -V`

thnx



Sat, 25 Nov 2000 03:00:00 GMT  
 Compile Perl5.4 on AIX 4.2 with Gcc 2.8.0

Quote:

>I got it running perfectly with AIX's cc, could send you my "perl -V"
>if you like.

>> If you are refering perl v5.00404, yes. I compiled it using gcc2.8.0 on aix
>> v4.2.1.0
>> I could email you the perl -V result if that is what you want
>Yes, please!
>Got the same problems you described with gcc 2.8.1, so I'm very
>interested in your gcc version of `perl -V`
>thnx

i had also some strange problems with configure. using ./Configure asks some
question you can answer by hand and worked for me. (using gcc2.7.2)

        walter

--
-----
'Real programmers confuse christmas and halloween,                 |
         because Dec 25 = Oct 31.'
-----



Tue, 28 Nov 2000 03:00:00 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. Where to Get Compiled Perl Module to run on AIX 4.2/4.3

2. Storable compile error on AIX 4.2

3. Problem compiling unser AIX 4.2

4. Perl5.004 on AIX 4.2 Installation problem

5. Help on Perl5.003 on Aix 4.2

6. Compiling Perl5.001m on AIX 4.1.3 using AIX C

7. building perl with gcc 1.40 on Ultrix 4.2

8. Compiling Perl 4.019 with gcc 2.1 on AIX 3.1.5

9. Perl won't compile (gcc 2.8, AIX)

10. prob compiling under aix 4.2.1 via gcc

11. Quota 1.0: hints for AIX 4.2 available ?

12. FastCGI on AIX 4.1/4.2?

 

 
Powered by phpBB® Forum Software