Help Installing Modules (CPAN) problems 
Author Message
 Help Installing Modules (CPAN) problems

Can someone Please help a very frustrated CPAN newbee.

        I need to install the following modules on my Red Hat 7.1
linux box in order to get a script to run called "dnsping".  The
script calls for the following modules.

MD5, Crypt::PasswdMD5, LWP::Simple, URI::Escape.

        Every time I try running the scipt I get this error



/usr/lib/perl5/5.6.0/i386-linux /usr/lib/perl5/5.6.0
/usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/
perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .) at ./dnsart_connect
line 54.BEGIN failed--compilation aborted at ./dnsart_connect line 54.

        Below is a snipit from the script dnsping found at
www.dnsart.com.  The script is supposed to update a central dns server
of any ip changes that occur on a linux box using a dynamic ip
connection to the internet.

##################################################
#
# Art of DNS FreeBSD / Linux client
# Copyright (C) 2001 ZeroHype Technologies Inc.

# 22-Jan-2001
#
# Requires the following modules (available from CPAN):
#
# Crypt::PasswdMD5 (relies on Digest::MD5)
# LWP::Simple
# URI::Escape
#
# The easiest way to get these modules is:
# perl -MCPAN -eshell
# then at the cpan> prompt type:
# install MD5
# install Crypt::PasswdMD5
# install LWP::Simple
# install URI::Escape
# for whatever modules you are missing
#
# Usage:
# dnsping [hostname] [password]
# where hostname and password can both be
# hardcoded in the program file. (See above)
#
# Revision History:
#
# v1.0.1 22 Jan 2001 (JasonW)
#        - Added support to connect on
#          alternate port, to bypass HTTP proxies.
#
# v1.0.0 09 Jan 2001 (JasonW)
#        - Initial version
#
##################################################

Note: I have followed the instructions and configured CPAN using

#perl-MCPAN -e shell,  Then I used the defaults to configure cpan.
The problem is that I can't get CPAN  to acutally work.  I have tried
to do installs for the required modules and I keep getting these
errors

***************************************************
this error occurs when I start CPAN
***************************************************

#perl -MCPAN -e shell

Use of uninitialized value in pattern match (m//) at
/usr/lib/perl5/5.6.0/Term/Cap.pm line 284.

cpan shell -- CPAN exploration and modules installation (v1.52)

****************************************************

****************************************************
Then If I try to install a module I get this error
****************************************************

cpan>install Crypt::PasswdMD5  

Please, install Net::FTP as soon as possible. CPAN.pm installs it for
you  if you just type
      install Bundle::libnet

****************************************************

I have tryed to install Bundle::libnet, and I just keep getting the
same error asking me to install Bundle::libnet.  I even tryed
reconfigureing CPAN by doing this

cpan>o conf init

That allowed me to get to the point where it asked me about proxy's
etc, and then the question started again.

Please, install Net::FTP as soon as possible. CPAN.pm installs it for
you  if you just type
      install Bundle::libnet

        Could someone please help me to get this CPAN installer
working, or could you tell me how to actually install the modules
manually vs using CPAN if it can't be used?


thank you

Dave LaPorte



Sun, 25 Apr 2004 05:28:10 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. module install problems with cpan module and gcc?

2. CPAN module install problems

3. Problem installing CPAN modules

4. Problem installing CPAN modules

5. problems installing CPAN modules on Win98, using nmake

6. Problem: Installing Modules with CPAN.pm

7. CPAN module Tk::BLT::Table install problem

8. Help having trobule installing a CPAN module

9. Help!!!! Prob during install CPAN modules

10. Help having trobule installing a CPAN module

11. newbie: howto install CPAN module in my home

12. ARCHLIB for CPAN-installed modules

 

 
Powered by phpBB® Forum Software