system("dir") fails etc... 
Author Message
 system("dir") fails etc...

I am running ActivePerl for the win32 platform. A problem arises when
I call the system() sub. I cannot execute any commands such as
system("dir"),system("cls") etc...The call just returns while printing
nothing on the console. These commands work when manually typing them
into a dos console, and the system() function call works while calling
it from a C program. I just don't understand why it is failing when
called from a script. Please help.


Thu, 12 Aug 2004 01:28:14 GMT  
 system("dir") fails etc...

Quote:

>I am running ActivePerl for the win32 platform. A problem arises when
>I call the system() sub. I cannot execute any commands such as
>system("dir"),system("cls") etc...The call just returns while printing
>nothing on the console.

Nothing happens?
What version of Windows are you running anyway?
What happens when you cut'n'paste this into a Command Prompt and execute it:
perl -we "system('ver');"

--
Petri Oksanen



Thu, 12 Aug 2004 08:18:39 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. system("cd /.../...") fails

2. system(("cp", "-Rf", "/tmp/a/*", "/tmp/b")); doesnt wrk

3. adding ".."(parent dir) to @INC

4. adding ".."(parent dir) to @INC

5. Perl -e `"dir a*.txt"`

6. "character class ""bug""

7. Failed "groups.t" test

8. perl4.036 fails "make test"

9. DBD-Sybase Problem - Failed "make test"

10. Perl 5.0005_02 fails "make test", db-btree and db-hash tests

11. DB_File: "make test" fails

12. DBI::Oracle fails "make test"

 

 
Powered by phpBB® Forum Software