Broken CPAN Module. IO modules no longer compile 
Author Message
 Broken CPAN Module. IO modules no longer compile

On Red Hat 5.0 Linux 2.0.32, perl version 5.004_01 I have managed to
load some modules off of CPAN so that my CPAN module no longer works.

In particular

$ perl -MCPAN -e shell
IO object version 1.20 does not match $ 1.15 at /usr/lib/perl5/i386-linux/5.00401/DynaLoader.pm line 172.
BEGIN failed--compilation aborted at /usr/lib/perl5/i386-linux/5.00401/IO/Seekable.pm line 50.
BEGIN failed--compilation aborted at /usr/lib/perl5/i386-linux/5.00401/IO/File.pm line 111.
BEGIN failed--compilation aborted at /usr/lib/perl5/CPAN.pm line 26.
BEGIN failed--compilation aborted.

Using 'r' in -MCPAN shell last night, I grabbed a few new packages as
recommended, one of them was IO.

Do I just need to install a more recent version of DynaLoader?

Obviously something isn't working well.  Any suggestions about
what to do an how to do it.  I would appreciate an answer by Email.
I will summerize to c.l.perl.misc.  If this is not the correct
place to ask, or if this is answered in some FAQ, please let me
know.  I have taken a quick look that the FAQs, but didn't find
anything appropriate.

-j

--
Jeffrey Goldberg                +44 (0)1234 750 111 x 2826
 Cranfield Computer Centre      FAX         751 814

Relativism is the triumph of authority over truth, convention over justice.



Wed, 28 Mar 2001 03:00:00 GMT  
 Broken CPAN Module. IO modules no longer compile

Quote:

>On Red Hat 5.0 Linux 2.0.32, perl version 5.004_01 I have managed to
>load some modules off of CPAN so that my CPAN module no longer works.

This stuff has bitten me in the past. You could try just re-compiling CPAN (or a
newer version).

--

Alastair




Wed, 28 Mar 2001 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Mod_perl breaks IO::Capture module

2. IO module && make problems (long)

3. Proposed module: IO::Filter [long]

4. IO module && make problems (long)

5. Can't load IO.so error when trying to install CPAN modules

6. compile modules on win32 (xsubpp broke)

7. err compiling IO module

8. Can't compile IO 1.20 module!

9. Can't compile IO 1.20 module!

10. Can't compile IO 1.20 module!

11. err compiling IO module

12. Compiling Modules with CPAN and VC++ on shared drive

 

 
Powered by phpBB® Forum Software