Server won't run Perl scripts 
Author Message
 Server won't run Perl scripts

I am currently using Netscape FastTrack Server 2.0 and Win95. When I call a cgi
script from a web page, I get the following message:

This server has encountered an internal error which prevents it from fulfilling
your request. The most likely cause is a
misconfiguration. Please ask the administrator to look for messages in the
server's error log.

When I check the error log in the server, I find the following:

[15/Mar/1997:23:54:51] failure: for host 127.0.0.1 trying to GET
/cgi-bin/calendar_3.0/calendar.cgi, send-cgi reports: could not send new
process (ERROR_BAD_EXE_FORMAT)

[15/Mar/1997:23:54:51] failure: cgi_send:cgi_start_exec
d:\server\docs\cgi-bin\calendar_3.0\calendar.cgi failed

I have .cgi and .pl associated with Perl.exe under Win95. The first line of the
script is correct (#!../bin/perl). I've also tried using Perl32.exe. I've tried
everything I can think of and I always get the same error messages. I'm sure
it's something simple, but I've been trying to figure this out for days and I'm
getting nowhere. I would GREATLY appreciate any help anyone could give me.

Alan Hathcock

P.S.

I'm also running a program called Cold Fusion. It works perfectly when I call
the Cold Fusion cgi script dbml.exe. Also, if it's not already apparent, I'm
new at this.



Thu, 02 Sep 1999 03:00:00 GMT  
 Server won't run Perl scripts


Quote:
> Subject: Server won't run Perl scripts

Sounds like a server problem, not a perl problem. Have you checked your
server's manual? Hope this helps!

-- Tom Phoenix        http://www.teleport.com/~rootbeer/

Randal Schwartz Case:     http://www.lightlink.com/fors/



Thu, 02 Sep 1999 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Server won't run Perl scripts (Fasttrack)

2. Please Help:My script runs on win32, it won't run on Unix

3. My script runs on win32, it won't run on Unix

4. Please Help: My script runs on win32, it won't run on Unix

5. perl 4 script that won't run under perl 5

6. script won't run...displays script text

7. Perl CGI scripts won't run without -w switch (under Apache 1.3.x)

8. Perl scripts won't run on Linux

9. IIS4.0 won't run perl scripts which call external commands

10. perl script won't run correctly inside emacs

11. Cron won't run my Perl Script

 

 
Powered by phpBB® Forum Software