PerlMagick with ActivePerl (perlis.dll) on NT4 / IIS4 wont load Magick.dll for Dynaloader.pm 
Author Message
 PerlMagick with ActivePerl (perlis.dll) on NT4 / IIS4 wont load Magick.dll for Dynaloader.pm

I cant get any PerlMagick perl script (.plx) to run on NT4 with
IIS4 web server via the ActiveState 522 Perl installation
perlis.dll ISAPI extension when entered from a URL
entered into a web browser.

I have been able to get non-PerlMagick scripts to run, and
also have been successful with scripts run from the comand line
(with .pl extension) - i.e. under the control of perl.exe

When I try and run a .plx script (under perlis.dll) from a browser
(http://webserver/websitename/makeimage/testscript.plx) the
browser displays:

'F:\InetPub\wwwroot2\websitename\makeimage\testscript.plx' script produced
no output

and the web-server error log (PerlIS-Err.log) shows:

*** 'F:\InetPub\wwwroot2\websitename\makeimage\testscript.plx' error message
at: 2000/01/07 15:05:50
Can't load 'F:/Perl/site/lib/auto/Image/Magick/Magick.dll' for module
Image::Magick: 126 at F:/Perl/lib/DynaLoader.pm line 169.

at F:\InetPub\wwwroot2\websitename\makeimage\testscript.plx line 8
BEGIN failed--compilation aborted at
F:\InetPub\wwwroot2\websitename\makeimage\testscript.plx line 8.

( testscript.plx line 8 is: use Image::Magick; )

I have:
1. Installed ActiveState perl 522 to F:/Perl
2. Installed ImageMagic 5.1.0 for nt, built the VC++ 6.0 project binaries
3. Copied and renamed the delegates nt file in c:\imagemagick
4. Added the imagemagick\isualmagick\bin directory to the path
5. Created a makefile for perlmagick:  perl Makefile.PS
6. run the makefile under nmake: nmake
7. installed perlmagick: nmake install
8. run the tests: nmake test, with results (summary):

Failed Test  Status Wstat Total Fail  Failed  List of failed
----------------------------------------------------------------------------
---
t/filter.t                   43    1   2.33%  7
t/montage.t     255 65280    19   15  78.95%  5-19
t/ps/read.t                   3    3 100.00%  1-3
t/ps/write.t                  2    2 100.00%  1-2
t/read.t        255 65280    44   24  54.55%  21-44
t/ttf/read.t                  3    1  33.33%  2
t/write.t       255 65280    33    5  15.15%  29-33
Failed 7/19 test scripts, 63.16% okay. 51/275 subtests failed, 81.45% okay.
NMAKE : fatal error U1077: 'E:\Perl\bin\perl.exe' : return code '0xff'
Stop.

PLEASE CAN SOMEONE HELP - I've spent a week
trying to get this to work now, without success. I dont like to give up,
but I'm running out of ideas. I've tried many variations
of the above, and tried uninstaling and reinstalling everything several
times.
I've also tried version 4.2.9 of the full ImageMagick / Perlmagick
distribution,
but that fails ALL 32 t/write tests and doesn't work with perlis.dll,
either.

I note also that after installing PerlMagick, as above, a PPM query does
not report a PerlMagick package as present. However, there is an
Image-Magick perl package available on ActiveState's website (at version
4.2.9, though) - do I need this ?? I've tried the above both with and
without this package present and it doesn't seem to fix the problem.

Many thanks,

Steve Taylor

-------------------------------------------------------------
G a l l e r y   C a c h a l o t
Fine Photographic Prints
http://www.*-*-*.com/



Wed, 18 Jun 1902 08:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Unable to load ISAPI dll perlis.dll

2. PerlMagick problems on NT4 / IIS4 with ActivePerl

3. XS DLL name clashes with DLL that needs to load (Win32)

4. PPM wont run, needs PerlCRT.DLL

5. taint check with PerlIS.dll/ISAPI (repost)

6. Win32::ODBC and PerlIS.dll on IIS

7. Opendir fails via perlis.dll

8. PerlIS.dll and IIS 3

9. PerlIS.dll headers in html

10. PerlIS.dll headers in html extra INFO

11. PerlIS.dll problem or something?

12. Win32::ODBC and PerlIS.dll on IIS

 

 
Powered by phpBB® Forum Software