File glob not working properly 
Author Message
 File glob not working properly

I want to use code looking something like this:

while ($file = <*.c>) {
        print "$file: \n";
        ... do other stuff

Quote:
}

but when I tried it I got

sh: /dev/null: permission denied

This was on a Linux 2.0.0 Slakware 3.1 using Perl 5.003.  However, when
I moved the script to a computer using Linux 1.2.13 Slakware 3.0 and
under Perl 5.001, it worked fine!  The man pages say it should work, I'm
guessing it might be Slakware that's at fault.  I've checked permissions
and even tried running the script as root, but it doesn't help.  I have
already built a simple workaround and just wanted to know if anyone out

responses.  Thanks! :)

Jeremy Queen



Wed, 10 Feb 1999 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Parsing text file not working properly

2. Parsing text file not working properly

3. IPC not working properly

4. cgi/pipes not working properly

5. small find2perl script not working properly...

6. MIME::Base64 Not Working Properly

7. SetOption not working properly (Win32::Internet)

8. BerkeleyDB make not working properly

9. INC not working properly

10. Module not working properly....

11. form-to-mail not working properly

12. Object destructors not working properly?

 

 
Powered by phpBB® Forum Software