problems building 5.004_01 on HP-UXB.09.00 
Author Message
 problems building 5.004_01 on HP-UXB.09.00

I'm trying to build 5.004_01 on a
`uname -a` = HP-UX foo B.09.00 A 9000/382 xxxxxxxxxxxx two-user license

Everything went OK except for a couple of things:

I had to remove '#line' directives from generated c files in the ext
directories to get them to compile. Since I had no perl available, I
had to use sed. I can barely contain my shame.

The compiler (not gcc) was complaining about NULLs in the input
file. Removing the '#line' lines fixed it. Probably a compiler
problem.

I'm getting this error when the POSIX module is being built:

        Making POSIX (dynamic)
        LD_RUN_PATH="/lib" ld -o ../../lib/auto/POSIX/POSIX.sl  -b -L/usr/local/lib POSIX.o    -lm
ld: supplemental symbol table required for module /lib/libm.a
ld: (Warning) did not generate an output file
*** Error code 1

This one is the show-stopper.

HP-UX is not my forte (Solaris is, for better or worse). Does anyone
know whats going on here? Any help would be appreciated. Upgrading to
a more recent version of HP-UX is not an option.

Thanks.

--
Stuart McDow                                      Applied Research Laboratories



Fri, 25 Feb 2000 03:00:00 GMT  
 problems building 5.004_01 on HP-UXB.09.00

Quote:

>         LD_RUN_PATH="/lib" ld -o ../../lib/auto/POSIX/POSIX.sl  -b -L/usr/local/lib POSIX.o    -lm
> ld: supplemental symbol table required for module /lib/libm.a
> ld: (Warning) did not generate an output file
> *** Error code 1

Taking out the '-lm' seems to have fixed that problem.

--
Stuart McDow                                      Applied Research Laboratories



Sat, 26 Feb 2000 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Problems Building perl on HP-UX B.08.00 A 9000/43S

2. Perl 5.00.3 under HP-UX 10.10 problems

3. Curses.pm on HP-11.00

4. Problem building perl5.004_01

5. ANNOUNCE: VCS::LibCVS 1.00.00

6. Problem wih DBD::Sybase 09.1- Set Autocommit fails after prepare

7. Problem wih DBD::Sybase 09.1- Set Autocommit fails after prepare

8. Alarm() problem with perl5.00.

9. DBD-Pg-1.00 install problems

10. problem installing libxml-enno-1.00

11. Problem Building Perl5 on HP-UX

 

 
Powered by phpBB® Forum Software